Support » How-To and Troubleshooting » HTML editor doesn’t work

HTML editor doesn’t work

  • When I’m writing a post there’s a button that says HTML. When I click in another window pops up which should contain HTML code (I assume) but it’s empty – this no matter how much or how little content is already in my post.

    I’m using FireFox browser on a Win XP machine.

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have the same problem, and it looks like they are ignoring it.

    From what I’ve discovered, this seems to be a Firefox problem. It works fine in IE, Opera, etc. This is on a windows machine.

    Yes, vinnym, based on reports and complians here it seems FF 1.5 was a premature release: a lot of things don’t work properly in it. So, you guys would do better posting these in their forum 🙂

    I’m using FF1.5.0.1 on WinXPPro, and the html window works as designed (when I activate the wysiwyg, of course). I see content in both write post and manage post screens. Maybe something with one of your options settings in FF? Or perhaps it’s XPHome you’re using, not Pro? My laptop is a bit different on Home than my desktop on Pro (which is why I’m going to put Pro on it shortly….)

    I’m booting the laptop to check with it as well, I’ll post back in a bit….

    Back…. yes, works fine on my laptop XPHome install as well.

    I’m having the same problem as the original poster. Vkaryl, you appear to be the first person I’ve seen post on this who is actually getting it to work right with FF.

    I’m on an XP Home machine right now. I’ll have to try it on my laptop at work tomorrow with XP Pro and see if I get any difference.

    The only thing I did to FF after installing it tonight was to install the Google Toolbar, which wasn’t easy and crashed FF, so maybe my FF is screwed up from that?

    OK, now I’m on my laptop running Win XP Pro, with the same version of Firefox and the same WP blog, and the HTML editor works fine.

    I would think the problem is caused by XP Home, but Vkaryl says it worked fine on XP Home. Two things are different on this FF installation: 1) I never installed Google Toolbar on this one, and 2) the home version had an extension for sending error reports to Mozilla (I think that’s what it was). The one that’s working fine has no extentions installed. When I get home, I’ll try removing that extension.


    I have FF 1.5x running on 3 (2 xp pro, one FC5 linux) machines and all work as expected with the “HTML” button.

    Perhaps the next interesting step would be to have those that don’t have it working post what FF extensions they have enabled and see if anything pops up from that?

    i’m running FF 1.5.x and have AdBlock, FasterFox, SearchStatus and the Google Toolbar installed and am having issues with the HTML button disappearing on me. I tried checking in IE and the HTML button nor the graphic buttons for the other commands work… the graphic buttons have been changed to grey boxes

    So I went home and uninstalled Firefox and then reinstalled it with no extensions. It still behaves the same, but it’s clear from the settings in the new installation that the old installation’s settings were saved and used in the new installation (except for the extensions that I didn’t install). I may have to do a cleaner uninstall and then reinstall. I’d have to figure out registry keys to delete and such. What a pain.

    I’m sure someone out there knows the answer to this but they just haven’t seen this thread yet. There must be some setting or conflict with other software or something that could be fixed that would make FF able to use the HTML button in the WP editor!

    Last night, I uninstalled FF again on that machine with Win XP Home, removed all registry entries that said anything about Firefox and some that referenced Mozilla. Reinstalled it with no extensions, and it’s still acting the same. Still working fine on my laptop with XP Pro, though. And I even installed the Google Toolbar on the laptop, and that didn’t mess it up. Any other ideas out there? If it’s not XP Home that’s messing it up, what else could it be?

    Off the top of my head, there are three obvious things that could be doing it:

    • Adblock extension
    • NoScript extension
    • Your JavaScript settings
    • The first two you can check for in Tools|Extensions (not alphabetical), and the second you can change in Tools|Options|Content. There is an “Enable Javascript” checkbox as well as and “Advanced” button. Make sure to check that all the Advanced options are Enabled.

      If that works, you can re-disable those little JS niggles one by one and keep checking to make sure the HTML box hasn’t broken.

      I had something even odder, where the box kept shrinking, but I gave up on it and abandoned the WYSIWYG editor 🙂

    edit: just so you know, Firefox practically doesn’t use the registry at all (only for assosciations and the start menu). It stores all your settings in a profile, which is located at:
    [system drive]:\Documents and Settings\[your username]Application Data\Mozilla\Firefox\Profiles\Default.[garbage]\

    Try changing your JS settings first, and if that fails, delete the whole of the Profiles folder and reinstall Firefox.
    P.S. This will destroy your bookmarks! If you want you can copy out the bookmarks.html file in your profile, and copy it back when done.

    I’ve had this problem with Firefox but I wanted to make sure it was just firefox and not WP. It turns out that the WYSIWYG doesn’t work on Opera and there is NO way that I am using IE.

    Thanks for the tips, gecko. I don’t have any extensions installed, but I did go and enable all the advanced options for javascript. Still no improvement. Also, when I uninstalled yesterday, I did remove the profile folder.

    I also made sure I had the same version of Java runtime environment on this PC as on my laptop (where it works fine), and that didn’t help either. Is there something else that sets the environment for a web page like this that could be different on the two PCs?

    – Steve

    Have any of you Windows guys tried the Bon Echo release – works fine on my Mac

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘HTML editor doesn’t work’ is closed to new replies.