Support » Fixing WordPress » html editor changes my html

  • First let me say that I am sorry if this question has been already presented and answered — but I searched and could not find any references.

    I am trying to insert a table, using xhtml, into one of the pages in my blog. Everytime that I try to insert html into the editor it deletes some of it and only returns part of it. I have even pasted direct xhtml for w3 and the html editor decided to delete part of it — some of the formating that I wanted to include such as alignment and such.

    Can anyone help me? Do you need more information?

    thanks for your time.

Viewing 15 replies - 1 through 15 (of 15 total)
  • try using full links, try using a better HTML editor, ” Example : Frontpage ” and try to be a little more descriptive of what your problem is, I have a database problem, Im just waiting for a reply, Damn . . . 1 hour of waiting and still no reply!

    OK, I obviously did not phrase my question properly. Let me try again.

    Specifically when I try to enter a formatted table into a page post and I save it part of the xhtml that I entered is deleted. Also sometimes a tag <pre> is inserted. For instance if I try to enter the following

    <caption>This is a caption</caption>

    it will be removed from my post after a save.

    Also in I try to add the <tbody> </tbody> pair they will also be removed.

    In short WordPress is making some decisions about my code and deciding to delete over which I have no apparent control.

    What I am asking is how do I prevent this from taking place.

    Also I do not understand your recommendations re Frontpage.


    Try turning off visual rich editing in Users:Your Profile. May have more luck…

    I am having a similar problem BUT it is happening to my Authors not me as admin..


    <img style="float: left; margin: 0px 10px 10px 0px;" width="" src="" />'
    that codes changes to this after you save and/or publish..
    <img width=”” src=”” />’

    Notice img “style” as is gone as is the values

    Rich editor is off as is xhtml validating correction check box.

    How do I fix this? I am using 2.0.3 (hoping 2.1 comes out for xmas ;-))

    Thank you.


    ps..strange is happens to Authors and not Admins??

    Its a pain in the… isn’t it?

    I had a similiar problem – wordpress was deleting all my <br /> tags and wantonly inserting empty <p> tags left, right and center!

    I had to edit the core files wp_texturize to force wordpress not to do this, even though I never use RTE. 🙁

    I even tried to use `<div class=”storyimg”>’ ..

    it lets me do as Admin but not as Author.. What gives??

    Katgirl ..Thank you! I’ll try that but where do i find that file ..been looking no find yet?

    Here’s the post for info on fixing the tag stripping.

    Sorry I can’t help you with your other problem. I’m assuming that you’ve created a dummy user and assigned it to “AUTHOR” and now when you write a post your html is being stripped from the Write >> Post page?

    Have you double checked that you’ve unclicked the RTE editor from your user accounts?

    Options >> Writing >>
    * Users should use the visual rich editor by default
    * Convert emoticons like 🙂 and 😛 to graphics on display
    * WordPress should correct invalidly nested XHTML automatically

    And don’t EVER use FrontPage to try to edit anything in WP – in fact, don’t EVER use FrontPage for anything period…. unless you print the entire excuse for a program out and use if for kindling in the fireplace….

    Ah…. can I ask what problems does FP produce?

    I use FrontPage 2003 when I design on my laptop – not their ridiculous HTML input (I code myself) but I use the program for visible purposes only.

    I Copy and Paste the HTML elements from Source View in my demo site and then paste that info into a blank FP page and go about designing things to suit myself.

    When I’m done, I use NotePad to code the design based on what FrontPage 2003 displayed. I open my style.css via NotePad too, and make whatever alterations I need.

    Just curious, really.

    I have a couple of clients who use FP – for everything. Then they pay me to fix their sites so they A: display; B: display “sort of right” in browsers besides IE; C: come anywhere CLOSE to valid code.

    I make about $300 a month on these clients. I’ve tried (for 3+ years now) to show them how to code without accessing FP at all. They refuse to bother – it’s “too hard”, “I can’t SEE what I’m doing”…. (in other words, if it’s not wysiwyg, they’re not willing to “get it”)

    *shrug* Fine, if they’d rather pay me to clean up the shit after using one of microsoft’s totally useless programs, I’m okay with it….

    [Well, I’m not, but the money’s nice. Sorry, FP is a total BALLS UP of a program…. And if you’re cleaning up after it in notepad, you’d be better off time-wise to buy TopStyle Pro from – there’s a trial version…. and unlike things like dw, it’s only $80 US.]

    No i dont use any editor but meta pad, kinda like wordpad but better.

    i should all 3 of these unchecked?

    * Users should use the visual rich editor by default
    * Convert emoticons like 🙂 and 😛 to graphics on display
    * WordPress should correct invalidly nested XHTML automatically

    Well, cafeRG, unchecked is good on all those, but you also need to make sure you’ve unchecked the RTE on all users – through your wp-admin/Users screen in the backend. Scroll to the bottom on each user screen (click edit to far right of each name) and uncheck the box….

    [Oh…. notepad2 is way better than metapad or anything else – it’s VANILLA…. it never throws any extraneous anything into your code, it edits html, css, php, js etc. equally “vanilla-y”…. get it from]

    Thanks vkaryl – I checked out TopStyle & TopLite, but its only for IE?

    I can intergrate it into my FP editor, but I like my editor the way it is. Its very familiar to me after 3years of playing.

    I agree with you that using FP for everything is very much like using Word and copy&pasting it into WordPress.

    Not good.

    I have NotePad 2 installed, but I’ve yet to use it. For some reason it never shows up in my Start Menu. I followed the instructions to the letter, placing NP2 in the same system folders and such like NP original, but I still can find it.

    Not to worry. I trudge along fine. Thanks again for your info. 🙂

    Nope. I run ONLY Firefox, have used TSP for the last oh, maybe, 3 years. (I have standalone IEs from 5.0 forward, which I NEVER allow to access the ‘net – I use them for viewing sites locally only….)

    There’s a little “plugin” called Mozilla Control that you download/install to enable preview with FF.

    But yes, you’re not letting FP run the show. You, however, are one in a trillion or so….

    Thanks vKaryl ..i unchecked everything and that still didnt work..

    btw you have an extra character in the notepad2 url “]” ..i’m giving it a try ..thanks..

    KatLady ..i am still checkin on your info ..thank you..

    is this editing/posting bug in 2.0.5 also?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘html editor changes my html’ is closed to new replies.