html doce shows instead of the website (16 posts)

  1. iceq
    Posted 2 years ago #

    Since updating, I occasionally encounter this:
    When visiting any page, in the dashboard or in the front end of the website, what I see is the page's code, not the page itself.
    When I reload, everything is displayed fine, but the problem re-appears in different locations.

    Using Chrome, latest version.

    What could this be?

  2. POage ... code? You mean like PHP code?

  3. iceq
    Posted 2 years ago #

    Yes Ipstinue, what I see is the html code (page source, not the PHP code) instead of the page itself.

  4. Okay, just to clarify, you're seeing:

    <p>blah blah</p>

    That's a server side issue.

  5. iceq
    Posted 2 years ago #

    Ipstenu, I spoke with Hostmonster and they said it's certainly not related to the server :(

    What else can it be?

    Please note that the problem doesn't occur always, and the moment I refresh the page, the page is rendered fine.

  6. What plugins are you using?

    PHP not rendering and showing actual CODE is usually a server side issue. I mean... the PHP engine's on the server. If it's not running...

  7. iceq
    Posted 2 years ago #

    I use not many plugins.
    The page looks like this


    Sometimes I even get this error:


  8. It's your server.

  9. iceq
    Posted 2 years ago #

    I am stuck with Hostmonster who claim it's not. I don't know what to do !

  10. What plugins are you using? Any caching plugins?

  11. iceq
    Posted 2 years ago #

    Yes I have W3 Total Cache installed, but disabled.
    I switched themes / disabled plugins / and the Hostmonster guy said he found an error with .htaccess and fixed it (didn't say what), and the problem just keeps coming back, in the blog's front page, as well as in the dashboard !

  12. What's in your .htaccess?

  13. iceq
    Posted 2 years ago #

    THIS :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
  14. Yeah, there's nothing that does that WP side, save (sometimes) caching plugins.

    You can try the old standby of turning off all your plugins, but I'd put dollar down on it being your server.

  15. iceq
    Posted 2 years ago #

    I tried that already , numerous times :(

    The guys at Hostmonster say its the script.


  16. This is twice today I've heard Hostmonster say things that are a bit weird.

    Anything on your server's error log?

Topic Closed

This topic has been closed to new replies.

About this Topic