Support » Plugin: Post to Google My Business » html codes visible in posts

  • Resolved Michieljf

    (@michieljf)


    Hi Koen,
    Posts on my wordpress website are immediately shown on Google Business, great. However, the lay-out is not optimal, as html codes (for links to images and pages) are shown. See the attached link. What could I do about this? Thanks, michiel

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Koen Reus

    (@koen12344)

    Hi Michiel,

    This is a result of the HTML to plain text converter. Because Google does not allow any rich text formatting in GMB posts (such as clickable text links), the plugin will insert the full URL -in brackets- after the link anchor text.

    I can imagine this behavior is not always desirable, but currently there is no easy way to turn it off. I’ll add a setting for it in the next update!

    For now -if you are comfortable editing a plugin file- you can turn it off by editing the file post-to-google-my-business/src/Placeholders/PostVariables.php.

    After line 24, where it says 'width' => 0, add a new line: 'do_links' => 'none',.

    That will stop the URL’s from being displayed in your GMB posts.

    • This reply was modified 3 months, 1 week ago by Koen Reus.
    Thread Starter Michieljf

    (@michieljf)

    Would be great if you could incorporate this in a future update. For now, editing the postvariables file works fine. Looks much better without the links. Thanks!

    • This reply was modified 3 months, 1 week ago by Michieljf.
    • This reply was modified 3 months, 1 week ago by Michieljf.
    • This reply was modified 3 months, 1 week ago by Michieljf.
    • This reply was modified 3 months, 1 week ago by Michieljf.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.