Support » Plugin: The Events Calendar » html characters appearing in the schema fields

  • Resolved Daniel Chase

    (@riseofweb)


    I don’t think there should be html characters showing in the schema description fields, just plain text. I think you may need to create a filter to strip out all html elements (ex. PHP strip_tags() Function) before writing it in the title and description fields.

    https://developers.google.com/search/docs/data-types/event

    This is what one of my events looks like:

    <script type="application/ld+json">
    [{"@context":"http://schema.org","@type":"Event","name":"Title","description":"<p>Some Text:\u00a0Some More Text</p>\\n","image":"

    Or if you don’t want to do this, is there some filter I can add to my theme’s functions where I can manipulate this text?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ali Darwich

    (@tokyobiyori)

    SUPER-O EL MOPO

    Hello Daniel,

    Thank you so much for your message. This is not a JSON error, but there’s definitely something we can do to improve the SEO as you mentioned, and to change

    <p>Some Text:\u00a0Some More Text</p>

    to

    Some Text: some more text about awesome keyword

    We’ll look into this a bit further and we’ll follow up with you later ๐Ÿ™‚

    Thank you!

    Plugin Contributor Courtney Engle Robertson

    (@courane01)

    Hey there! This thread has been inactive for a while so weโ€™re going to go ahead and mark it Resolved. Please feel free to open a new thread if any other questions come up and weโ€™d be happy to help. ๐Ÿ™‚

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘html characters appearing in the schema fields’ is closed to new replies.