Support » Fixing WordPress » HTML button in TinyMCE missing in WP 2.1

  • Steve

    (@stevejohnson)


    So I upgraded to 2.1 and the HTML button in TinyMCE editor is missing. I use it frequently — where did it go and how do I get it back?

Viewing 15 replies - 1 through 15 (of 29 total)
  • I’m missing almost all the buttons in the TinyMCE editor; all I have are Bold and Italic.

    Steve

    (@stevejohnson)

    Sheppy, the cure for THAT one is to dump your browser cache. In IE, go to Tools > Internet Options, and click the ‘Delete Temporary Internet Files’ button. In Firefox, use Tools > Options. Click the ‘Advanced’ tab, the the ‘Network’ tab and click the ‘Clear Now’ button on the cache line.

    You can try to insert

    header(“Content-type: text/javascript; charset: UTF-8″);”

    after
    “@ require(‘../../../wp-config.php’);”

    in the file “/wp-includes/js/tinymce/tiny_mce_config.php”

    Thanks, Steve, that did the job.

    Yes! What happened to the HTML button? I use that with almost every post. This is a serious loss of functionality. How can it be restored?

    Found it! stevejohnson, if you’re still listening, this is what you have to do:

    Open wp-includes/js/tinymce/tiny_mce_config.php in an editor and go to the line that starts “$mce_buttons = apply_filters(‘mce_buttons'”. You’ll see the list of buttons on the toolbar in there. After “‘wp_help’,” add “‘code’,”. Reload and you should see the button.

    Special bonus: I found a bug in there which is unrelated to this but still interesting. The button “wp_adv” toggles the “advanced” toolbar. The contents of the advanced tool bar are kept in between “wp_adv_start” and “wp_adv_end”. But in that file, “wp_adv” is *after* “wp_adv_start”. This means that the button to display the advanced toolbar is *on* the advanced toolbar! So there’s no way to turn it on, apparently. If you swap “wp_adv” and “wp_adv_start” in that same file, you’ll discover a whole bunch of new neat stuff.

    You realize the “HTML” button you just added is the same as clicking the “Code” tab while on the post editor?

    As for the advanced toolbar: Just hit alt-shift-v (Firefox) or alt-v (IE) to toggle it.

    You realize the “HTML” button you just added is the same as clicking the “Code” tab while on the post editor?

    As for the advanced toolbar: Just hit alt-shift-v (Firefox) or alt-v (IE) to toggle it.

    The CODE strips out some of the HTML when you write a post in the visual tab, so it’s not really the same. I installed upgraded 2.1.1 on an office WP installation yesterday and the HTML button was there in the visual editor next to the HELP button. But today when I upgraded to 2.1.1 for a different install, there is no HTML button.

    Also, do you know what the toggle keystrokes for the advanced toolbar are on a Mac?

    The button that should be showing up is the “HTML” button, which is located here in your WordPress install:

    /wp-includes/js/tinymce/themes/advanced/images/code.gif

    Go here to what it looks like:

    http://www.creativedepartment.com/blog/wp-includes/js/tinymce/themes/advanced/images/code.gif

    I’ve cleaned out my cache, edited the tiny_mce_config.php file per Sluggo’s suggestion, deactivated plugins, but I still can’t seem to get the HTML button to appear. I know that it’s supposed to be there… Any ideas?

    Same as above reply here. All I can see from post panel is 14 buttons; bold, italic, link, b-quote, del, ins, img, ul, ol, li, code, more, lookup, and close tags.

    I tried the instruction from sluggo that change tiny_mce_config.php, but it didn’t do any change.

    Anyone had solved?

    I had the same problem w/wp2.1. I looked through the source code and I found that wp loaded ‘quicktags’ toolbar by default instead of ‘wp_tiny_mce’ toolbar.

    You can find this code uder /wp-includes/general-template.php. At line 823, you may see

    <div id="quicktags">
    	<?php wp_print_scripts( 'quicktags' ); ?>
    	<script type="text/javascript">edToolbar()</script>
    	</div>

    To make tinymce working, change
    <?php wp_print_scripts( 'quicktags' ); ?>
    to
    <?php wp_print_scripts( 'tiny_mce' ); ?>
    and delete
    <script type="text/javascript">edToolbar()</script>
    line.

    With this change of code, you can see tinymce toolbar at least, but for some reason, you cannot see advanced tool bars (at the current version, 2.1.2, of wordpress). To make it work, I followed the instruction of sluggo.

    Go to /wp-includes/js/tinymce/tiny_mce_config.php file.
    At line 32, you can see
    $mce_buttons = apply_filters('mce_buttons', array('bold', 'italic', 'strikethrough', 'separator', 'bullist', 'numlist', 'outdent', 'indent', 'separator', 'justifyleft', 'justifycenter', 'justifyright', 'separator', 'link', 'unlink', 'image', 'wp_more', 'separator', 'spellchecker', 'separator', 'wp_help', 'wp_adv_start', 'wp_adv', 'separator', 'formatselect', 'underline', 'justifyfull', 'forecolor', 'separator', 'pastetext', 'pasteword', 'separator', 'removeformat', 'cleanup', 'separator', 'charmap', 'separator', 'undo', 'redo', 'wp_adv_end'));

    Change the order of
    'wp_adv_start', 'wp_adv'
    to
    'wp_adv', 'wp_adv_start'

    Now Tinymce works with advanced toolbar w/o using other plugins!

    The above didn’t work either. (webophir). Same issue here. IE and Firefox on PC, Firefox on Mac. This is not good.

    There’s two possible ways to overcome this TinyMCE problem. One is enable javascript in firefox settings (sory i don’t use IE) and two, upload the all tinymce files/folders and overide the old ones. More info and instructions go to http://www.romicozone.com

    I have the same problem. The strange thing is that i have a few blogs all running 2.12 and some have the correct visual and html editor options working and others don’t.. seems to somehow be corrupting in certain circumstances.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘HTML button in TinyMCE missing in WP 2.1’ is closed to new replies.