Support » Theme: Integral » HTML being stripped from footer even though it says “Custom HTML allowed”

  • Resolved the_tim

    (@the_tim)


    At some point something changed in the theme to strip HTML out of the “Copyright Text” field when I enter customization mode and attempt to edit the footer. I had links in this field, but when I tried to edit it to add new links, it broke the whole thing.

    What file do I need to edit to restore the ability to have HTML in my footer?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author themely

    (@themely)

    Hello,

    We haven’t made any changes to the footer file since the last update. It’s possible that something else is the cause of this issue.

    Can you share the link to your site so I can have a look?

    Thread Starter the_tim

    (@the_tim)

    My site is https://dispatches.fm, but for now I just manually updated footer.php to include my footer with HTML since the customizer was stripping it all out.

    I’m not saying this happened in the last update. I haven’t tried to edit my footer for over a year probably, so it could have been a change quite a while ago. I saw in another thread on here that you “added code to sanitize certain fields for security reasons” and I was wondering if the copyright-text part of the footer was one of those, even though it still says “Custom HTML allowed.”

    Theme Author themely

    (@themely)

    Yah that’s strange because I tested it on our development server without any issues. But I will check again.

    Open the console in your browsers developer tools when viewing your site. It’s possible your audio player is causing some interference.

    Just noticed this post. I have the same problem, was working a month ago. Now any html I type in the custom html allowed field doesn’t make a difference. I.e. it saves and then when. you go back into the customiser the changes are reverted back.

    Do you have a solution to this?

    If there is not a solution is there a workaround for now the I can apply?

    • This reply was modified 1 year, 1 month ago by ianrobbs.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘HTML being stripped from footer even though it says “Custom HTML allowed”’ is closed to new replies.