WordPress.org

Forums

.htaccess works but no automatic changes (13 posts)

  1. travisj2002
    Member
    Posted 10 years ago #

    I recently installed wordpress over on a dreamhost server. My website http://www.???.com has the wordpress files at http://www.???.com/wordpress/

    index.php and .htaccess are in the main section: http://www.???.com/

    So .htaccess & permalinks work, I can manually copy the text into .htaccess. However, WordPress will not automatically update it (patricularly annoying when adding/changing pages). I have tried setting .htaccess to 666 or 777, but neither work. I don't think its an issue like AllowOverride, since .htacess works, but WordPress just won't update it.

    Any suggestions?

  2. moshu
    Member
    Posted 10 years ago #

    Your .htaccess file should be in the same directory as your WP install.
    http://codex.wordpress.org/Using_Permalinks#Where.27s_my_.htaccess_file.3F

  3. travisj2002
    Member
    Posted 10 years ago #

    Sorry I had read another post that said it should be where your index.php is.

    But, I tried putting this in my wordpress install directory. wordpress still doesn't automatically update .htacess

  4. travisj2002
    Member
    Posted 10 years ago #

    Another possible clue:

    under Manage-->files
    it thinks that .htaccess and the main template (index.php) don't exist.

    They clearly do, they are visible by ftp, shell, and most of all the website works.

  5. moshu
    Member
    Posted 10 years ago #

    I never use Manage > files.
    But if you have to move the .htaccess file I'd start with a clean one in the WP root directory, make it writable and let WP to write the rules into it.
    If you have WP installed in a subdirectory, but your "short and sweet" index is at the root of your site - then according to some gurus around here you need the .htaccess in both directories!
    See this Codex page, especially #7. under "Giving WordPress Its Own Directory"

  6. travisj2002
    Member
    Posted 10 years ago #

    Hm, I've tried it in the root directory, the wordpress directory, and now in both directories.

    permalinks only work when .htaccess is in the root directory and in both directories. However, wordpress won't automatically update .htaccess regardless (even with permissions set to 666 for both files).

    I may just have to be stuck with manually updating .htaccess when I add pages.

  7. amossin
    Member
    Posted 10 years ago #

    I'm having the same problem. This might shed some light over it; the automatic rewriting used to work just fine when i hosted my testsite as http://mydomain.org/wordpress. But then i instructed apache to serve wordpress at the root, so now my site is http://moydomain.org. Then the automatic rewriting stopped, although .htaccess still works fine if I add my own rules.

  8. Kiddeath91
    Member
    Posted 10 years ago #

    moshu's suggestion sounds the best. I saw this a long time ago on these forums and it might work for 1.5:

    Creat new blank .htaccess file on desktop, FTP to site (root directory of WP install)

    Change CHMOD permissions to 777. Open Admin > Options > Permalinks and set permalinks preferences. WP will (should) write to the .htaccess file.

    Change permisions 644. Don't ever touch again.

  9. johnoz
    Member
    Posted 10 years ago #

    I have the same issue as travisj2002. I also have to manually update htaccess. I have tried all above suggestions and none work for me either

    Maybe a bug???

  10. johnoz
    Member
    Posted 10 years ago #


  11. nanobar
    Member
    Posted 9 years ago #

    I have had this issue since version 1.2. My theory: when the install is in a subdirectory, WordPress doesn't know to look upwards in the file structure for the .htaccess file. That's why it says it doesn't exist.

    For example: ../ for the path instead of ./ or just /

    So it might be an issue with one of the functions in the /includes area.
    I tried the suggestions above and still no luck - I am editing the .htaccess file by hand each time now.

  12. moshu
    Member
    Posted 9 years ago #

    If you have wordpess installed at example.com - you need the .htaccess there, i.e. in the root folder of your site.
    If you have WP installed in example.com/blog - put the .htaccess file in /blog directory.

  13. trevorturk
    Member
    Posted 9 years ago #

    dude! this is a dreamhost issue, and there's a hack/fix:

    http://trac.wordpress.org/ticket/1616

Topic Closed

This topic has been closed to new replies.

About this Topic