WordPress.org

Forums

.htaccess woes (8 posts)

  1. billymo
    Member
    Posted 4 years ago #

    Ok, I've tried everything I could find. I had no .htaccess file. Yes, I made sure I viewed invisible files on the server. So, I created the file, uploaded it to my server into the WP root folder (the same one that has wp-admin, wp-content, and wp-includes). I then gave it permissions 666 to make sure I could write to it. Went back into WP tried to save custom permalinks, nothing. I've moved the file into wp-admin- didn't work, I moved it back. I've changed the permissions to 777 just to make sure that wasn't it- didn't work either. I even went as far as forcing it to understand it was on an Apache server by using the var.php method of commenting out the Apache line and adding the new one. All of this, and I still error out when I try to go to any other page but the front page using "pretty permalinks" structure.

  2. Joseph
    Member
    Posted 4 years ago #

    I think if your wordpress is installed in a sub-directory, .htaccesss needs to be in root not the wordpress folder.

  3. billymo
    Member
    Posted 4 years ago #

    I tried it there as well. My root directory contains folders etc, mail, public_ftp, public_html, tmp, access logs, and www. I installed wordpress in public_html, that's where I had the file before. I just moved it to root again just to make sure, with no luck. Thanks for your answer. I really appreciate it, but we're still not up and running.

  4. Tara
    Volunteer Moderator
    Posted 4 years ago #

    I have my .htacces in the WP root (as you described yours in the initial post) and it works fine.

    Have you tried:

    -re-saving your permalink structure at Admin panel>>>Settings>>>Permalinks. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    Review this before using permalinks:

    http://codex.wordpress.org/Using_Permalinks
    http://codex.wordpress.org/Using_Permalinks#Where.27s_my_.htaccess_file.3F

  5. DigitalSquid
    Member
    Posted 4 years ago #

    Try switching to a different (ideally the WordPress default if you're not using it) and see if you get the same problem.

  6. billymo
    Member
    Posted 4 years ago #

    t-p: I've been going back, testing and attempting to save after each change I make, have done just what you've said, and tried to save again. It provides the same directions saying that .htaccess is not editable (which could be a server setting that I don't have access to) and to manually change it to the structure provided (which it has already been changed to). I had to create the .htaccess file, and I've read up on both of those articles you quote. Thank you.

    Charity: Try switching to a different...? Lol. You're trying to trick me, aren't you? Like it's not already confusing enough that my server seems to work differently than everyone else's. j/k. Thanks.

  7. David Gard
    Member
    Posted 4 years ago #

    I assume he menat 'Theme' - may be an issue with the theme that you are using.

    All the above advise looks sound, so it's unusual that none of this has fixed your problem. Who is hosting your website? My be worth contacting them and ensure that LoadModule rewrite_module modules/mod_rewrite.so is uncommented in your 'httpd.conf' file.

    Also, not sure what you put in your '.htaccess' file, but try creating one and adding just this. It's the default one WP created for me -

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  8. govpatel
    Member
    Posted 4 years ago #

    I installed wordpress in public_html, that's where I had the file before. I just moved it to root again just to make sure, with no luck.

    You said that you installed your wordpress in public_html that is root so all your wordpress files and folders need to be in public_html.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.