Support » Fixing WordPress » htaccess problem – 404 error

  • Hello guys, we have a problem with htaccess file.

    “404 Not Found

    The request /sklep/kurs-trenera-personalnego/ was not found on this server.”

    text above shows on every page and post on our website. Home page and wp-admin works always.

    When I refresh htaccess content (without any changing) – everything works perfect… for few minutes. Pleas help us 🙂 szkoleniatrenerskie.pl

    htaccess content:
    [code]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    [/code]

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • @bartos19955,

    This usually happens if your .htaccess file got deleted or something went wrong with the rewrite rules. What you need to do is fix your permalinks settings.If you don’t like the video or need more instructions, then continue reading.
    Go to: Settings » Permalinks, and simply click on Save Changes button.

    This will update your permalinks settings and flush rewrite rules. In most cases this solution fixes the WordPress posts 404 error. However, if it does not work for you, then you probably need to update your .htaccess file manually.

    Login to your server using FTP, and modify the .htaccess file which is located in the same location where folders like /wp-content/ and /wp-includes/ are located. The easiest thing you can do is to temporarily make the file writeable by changing the permissions to 666. Then repeat the original solution. Don’t forget to change the permissions back to 660. You can also manually add this code in your .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Everything looks fine to me. Have you tried checking with your hosting provider?

    Peramalinks are setting as it was earlier. Earlier it works perfect. We don’t change anything when pages gone down.

    When I edit .htaccess (only open and save, without any changes) – it’s fine. After few minutes website is broken up again. Permissions for this file are set to 666.

    Our provider told that fromthem is ok.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘htaccess problem – 404 error’ is closed to new replies.