WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] htaccess problem

[Resolved] htaccess problem

  • Angela

    @angelazou

    Hi,

    I’m installing a copy of WordPress locally, and I run into a problem when trying to upload a file (it also appeared when I try to change the permalink structure). It says that I don’t have the write capability to create the folder to host the file.

    Here is my htaccess content
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Angela

Viewing 9 replies - 1 through 9 (of 9 total)
  • Clayton James

    @claytonjames

    I think the error might indicate that you must temporarily change the permissions on your .htaccess file and your /wp-content directory, so that WordPress might:

    a) write to your .htaccess file, and change your permalink structure for you, and..

    b) create the uploads directory for you when you upload to the media library the first time.

    Some reference material. Changing File Permissions

    Some frequent discussions and solutions on very similar issues. “if this file were writable”

    Angela

    @angelazou

    I checked the folder, and it seems like both the .htaccess file and wp-content folder is readable and writable if accessed from my account (I’m performing a local installation with XAMPP), but only readable by other groups.
    So, I need to figure out how does WP attempt to write the file, on whose behalf to be more precise? If it’s accessing via my account, then the problem should be something else. In addition, I do notice that XAMPP do ask me to enter my administrative password when moving files.

    Angela

    Angela

    @angelazou

    I don’t understand why I’m not able to write to any files. Mac is unix based, and from what I can see, htaccess and wp-content both have 755 permission. Why am I not able to write to any of the files?

    Angela

    Clayton James

    @claytonjames

    It might be because the user the web server runs under is trying to write the file or directory (rather than as your user account). As long as you are working locally, maybe try changing .htaccess to 666 (or 777) and /wp-content to 777. If that works, you can change them back to 644 and 755 afterward.

    Angela

    @angelazou

    I later changed the files to be 777, but still no luck. I think the issue may not be related to permissions. Maybe it’s my htaccess rules?

    Angela

    Angela

    @angelazou

    Any suggestion?

    Clayton James

    @claytonjames

    I don’t think .htaccess rules would affect the issue. I think it comes down to either file/folder permission or ownership problems. Does the web-server account have permissions on your wordpress directory?

    For example: if your installation was something like /xampp/htdocs/wordpress – is the wordpress directory owned [username]:[web-server]? Or is it [username]:[username] ? I think the directory you installed wordpress in may need to be writable by the web-server. I’m afraid I’m not much of an XAMPP user, so I’m not sure of the default paths.

    Angela

    @angelazou

    Thanks Clayton, but I think I have it figured out. It turns out that on Macs, I need to enable the ‘Apply the option to all enclosed items’ option in addition to make the file/folder writable.

    Angela

    Clayton James

    @claytonjames

    Ahhh.. Glad you found a solution!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] htaccess problem’ is closed to new replies.
Skip to toolbar