[resolved] .htaccess not being updated properly when new page created (4 posts)

  1. ianmcn
    Posted 10 years ago #


    I am in the process of setting up wordpress for someone, and I want to give them permalinks. I have these running fine, until I try creating a new page - when I do that, it tries to update the .htaccess file (chmod 777 BTW) but instead of adding to it it rewrites the whole lot again after the existing set of rules! This causes an Internal Server Error.

    So in other words, if I have permalinks on - as soon as I create a page I totally disable the blog! Surely this has to be a serious bug - has anyone found a way round it?

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    No bug (or it would be widely reported).
    .htaccess should be 666 at most - never 777

    Does your .htaccess contain any other rules ?
    You are running 1.5.2 ?
    Are you creating the .htaccess and filling the rules first, or chmoding an empty .htaccess for wp to write to ?

  3. ianmcn
    Posted 10 years ago #

    got it sorted...

    I was creating the .htaccess and filling in the rules, tried emptying it and letting WP write to it and it worked.


  4. Joebar
    Posted 10 years ago #

    Same exact problem here ian -- (this was with tho, haven't tried with 1.5.2)

    I changed the permissions and I just update it manually. It's very rare that it requires updates.

    and to podz, my .htaccess does contain some hotlink protection stuff at the bottom -- so maybe that has somethin to do with it.

Topic Closed

This topic has been closed to new replies.

About this Topic