WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
.htaccess issues (5 posts)

  1. Strictly Software
    Member
    Posted 1 year ago #

    Since moving to WP 3.8 I have had major issues with ONE of the sites I run on the same Virtual Server.

    All had same plugins installed.
    Both used WP Super Cache
    One used Cloudflare - this is the problematic site - however turning it off does nothing to resolve the issue.

    The issue is the homepage is always cached. Whether I am logged in as admin, add a ?r=1 querystring or say "don't cache front/home page"

    In the comments at the bottom of the page I can see

    <!-- Dynamic page generated in 2.328 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-12-20 07:35:18 -->
    <!-- super cache -->

    So an 8 day old cached homepage with old content - going to page 2 is fine new content is shown. The search box doesn't work either now for some reason.

    I have tried changing themes, turning all plugins off, removing all .htaccess rules that were working but nothing helps.

    So I installed your plugin which I had issues with before on something I cannot remember - however this didn't solve the issue. Even though WP Super Cache was totally removed and your plugin installed I still got WP Super Cache comments on the homepage.

    Also I had this error constantly showing

    W3 Total Cache error: It appears Page Cache URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately disk enhanced page caching will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.

    However when I check the .htacess file ALL the rules you say should be there ARE there.

    The problem is obviously that you are testing for an "OK" code from your test to the homepage but because the homepage is blocking or locked it doesn't return what you expect e.g

    htaccess file contains rules to rewrite url http://www.darkpolitricks.com/w3tc_rewrite_test into http://www.darkpolitricks.com/?w3tc_rewrite_test which, if handled by plugin, return "OK" message.
    The plugin made a request to http://www.darkpolitricks.com/w3tc_rewrite_test but received:
    200 OK
    instead of "OK" response.

    So even with the right rules in the file the homepage is locked. I have even tried deleting the home.php file from the theme but it still shows up.

    Re-starts of apache, cleared browser cache, turned off cookies/JS, turned off Cloudflare altoghether. Even with your plugin working with Opcode APC to get round the .htaccess error message I still got the same homepage.

    So I have some sort of weird issue with the homepage and changing caching plugins and front end services like Cloudflare does nothing to help me.

    I have no idea what is going on and this only started after the upgrade to WP 3.8.

    I thought your plugin might have helped - I had to delete a load of files manually and copy them over from your wp-content folder to the main one. Even cleared out .htaccess and let your rules exist alone in it but the homepage still is locked - viewing the souce will show you the comments at the bottom.

    Any help from ANYBODY would be much appreciated.

    http://wordpress.org/plugins/w3-total-cache/

  2. Strictly Software
    Member
    Posted 1 year ago #

    Right I've solved this major pain in the ass!

    There was a page in the root of my site /public_html/index.htm

    I viewed the source and it was exactly the same source as that of the homepage if I viewed it with the WP Super Cache comments and all the rest of it. The build date was exactly the same as the comments in the site.

    I delete this page and now the site is working again!

    Finally.

    Why this page was cached as static HTML and put in the root of my site I have no idea. The index.php file was there but I guess (just like IIS) that you set a precedence of files to run e.g default.htm, default.asp, index.htm, index.asp etc) and the .htm was top of the list.

    The index.php file is the one all the WP code throws everything through with their massive overkill of PHP instead of adding .htaccess rules into the file to handle /tags/, /category/, /post/date/blah etc. If you actually look at the code that has to run on every page load just to work out what kind of rewritten URL it is - then you will CRY! Why not just take the users settings for permalinks and make .htaccess rules for each major branch.

    Anyway I digress it seems to work for now and if anyone else has the same problem check for an index.htm file in their root and delete it. Whether Super Cache put it there or not I don't know but it buggered me up for 10 days!

  3. Strictly Software
    Member
    Posted 1 year ago #

    I have found the solution.

    I have no idea how WP Super Cache put the file into the root of my site but it created a hardcoded .html file called index.htm under public_html/index.htm

    I am guessing just like IIS Apache has some sort of priority where it runs certain file names first before others e.g

    index.htm
    index.html
    index.php

    Or something similar.

    Once I deleted this hardcoded file from my root everything started working again fine.

    I have no idea how WP Super Cache put it there at 7am on the 20th (a day I was in bed with a hangover) and I have never manually copied the generated source, created a file and copied it up to the site.

    Maybe a check for this would be good. OR maybe it's some feature I don't know about e.g Stephen Fry Lockdown mode for homepage etc. Not that I ever turn it on.

    I just thought I would pass this on for other people with similar issues.

  4. HoneyTrek
    Member
    Posted 11 months ago #

    i don't have any index.html file in there, but still getting issues. any thoughts guys?

  5. Strictly Software
    Member
    Posted 7 months ago #

    What about index.htm or index.html or default.php default.htm default.html and home.php etc etc

    In IIS there is an order they are run in. So Check for all of them.

    Also I have noticed that even when I am logged in as admin there are no "Edit" buttons next to each article at the top like there used to be.

    It's like it doesn't know I am admin. Also it means I have to go into the back end, run a search to do any editing.

    Why this has changed I don't know. I am thinking of a different plugin maybe http://wordpress.org/plugins/quick-cache/ which is recommended by s2member which is a framework for free membership and a good plugin if you need to sell subscriptions or payments on your site.

    Worth a try.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic