WordPress.org

Support

Support » Installation » .htaccess file missing. Need some help

.htaccess file missing. Need some help

  • Well, I’ve got it installed. I can get to any of the individual pages by typing in the URL. Sadly, whenever I click on a link to things it takes me back to the index of the folder my wordpress is located in.

    I’ve gone in through my FTP and noticed that I lack any .htaccess in my wordpress folder or anywhere else.

    So… what am I missing here and where can I find the .htaccess file at (it wasn’t in the original download I got either unless I completely overlooked it).

    So if anyone could give me some advice on what I need to do to fix this problem, please feel free.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The .htaccess is automatically created when you update the permalinks, if WordPress has the ability to do that. If it doesn’t have that ability (due to your server configuration), then it will spit out a list of rules which you need to put into the .htaccess file manually.

    The .htaccess file is not included with WordPress because it will be different depending on your site. So go to Options->Permalinks and update your permalinks. Then scroll down to find the rules that you need to put into the .htaccess file. Just create a text file, paste those in, rename the file, and put it in your main wordpress directory via FTP.

    Okay… Well I just updated my permalinks. It said “Permalink structure updated.”

    That’s it.

    I’m using SmartFTP to view the folder, but I still don’t see the .htaccess file in there.

    The folder has 777 permissions. I’m pretty certain that means that it has write permissions. Should I try to remove the permissions and write an .htaccess file on my own and upload it with the information that WordPress spits out when it can’t write the .htaccess file?

    Well… my attempts at changing the permissions to the folder to get the information out that I need to hand prepare a .htaccess file have failed.

    It appears my hosting is on a WinNT setup… It obviously has PHP and MySQL, but I still haven’t solved the problem and if anyone has any help they can offer me, I would very much appreciate it.

    This would be the second blogging setup I’ve tried, I’d hate to have scrap it and go to yet another blogging setup since WordPress looks like it has what I want/need, but if I can’t get it to function properly, then I’ll have to find a solution that does. 🙁

    Hey Johnny, I have never used SmartFTP but see if there is an option in it to view hidden files, that has happened to me. Very often that option is not on by default by FTP applications.

    I checked and show hidden is turned on. I will attempt to disable and re-enable the show hidden just to be sure.

    Yep… SmartFTP is showing hidden files and the .htaccess file is still missing from the installed folder. I have clicked the update permalinks thing about twenty times (using different options, but getting the same results).

    So… what do I try next?

    I am far from an expert, but I would create an empty text file using a pure text editor (not Word) and name it .htaccess and upload it to where it’s missing from. And make it writable too.

    Okay… I’ll give that a shot and see what happens. Maybe it just can’t create the file but it could edit it?

    I can’t adjust the read/write access on the server since it’s a windows based server.

    I did however, create a file called x.htaccess and uploaded it via frontpage (which granted the file read/write/execute properties) and then renamed the file via SmartFTP to be called .htaccess…

    So I now have a file called .htaccess sitting in my blog folder. I have run the Permalinks update again and still the .htaccess file remains empty.

    I also went into my control panel for my site and noticed that under the PHP setup that it does have .htaccess defined there as one of the types of files supported. I don’t know if this information helps or not.

    Any more ideas for me?

    Sorry, not from me, now you need an expert, which I’m not (I have my own 404 issues) 😉 good luck!

    “I can’t adjust the read/write access on the server since it’s a windows based server.

    I did however, create a file called x.htaccess and uploaded it via frontpage (which granted the file read/write/execute properties) and then renamed the file via SmartFTP to be called .htaccess…

    So I now have a file called .htaccess sitting in my blog folder. I have run the Permalinks update again and still the .htaccess file remains empty”

    **********************************

    IIS doesnt use .htaccess

    therein lies your problem.

    Thanks for the attempt to help pdoran. Might just come down to me having to scrap this idea unless someone knows what I need to do next.

    what you need to do next is either ask your host to be switched to ‘NIX box (one using Apache) or you need to investigate .htaccess alternatives.

    What you are presently trying to do is NOT going to work, ever, with your current setup.

    Johnny, Whooami has your reason, she knows way more than I.

    pdoran = pat

    Yeah… Thanks Whooami. Any ideas on where I might find more information concerning how to get it to work without the .htaccess?

    If not… does anyone have any ideas about other blogging software that I could use instead of wordpress that will work on my server?

    (doesn’t have the option to move to a nix based server at the moment)

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘.htaccess file missing. Need some help’ is closed to new replies.