Support » Plugin: W3 Total Cache » htaccess file in self-hosted CDN

  • Hello,

    Whenever W3 Total Cache uploads files to my self-hosted CDN, .htaccess gets replaced with htaccess (without dot) rendering all htaccess rules, including those written by W3 Total Cache itself unusable, unless I add the dot to the file.

    Is this a bug or is there a reason why this is happening?

    Thank you kindly in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor gidomanders

    (@gidomanders)

    Could you tell us anything about your server setup and the settings you’re using in W3 Total Cache? Then I can try to replicate the issue.

    bgdstr

    (@bogdanstratulat)

    Hello,

    Please keep in mind that W3 Total Cache requires quite a few settings in order to properly work with CDN providers, so, please double check the following settings:

    Plugins -> Installed Plugins > Settings
    General Settings – enable Page Cache
    Select Disk:Enhaced as a caching method
    scroll down and disable Minify, Database Cache and Object Cache
    scroll down and enable Browser Cache
    scroll down and disable CDN and Reverse Proxy,
    Click on Miscellaneous tab and enable the following option: Verify rewrite rules
    all other options should be disabled
    disable all Debug options
    Click Save all settings.
    From the left menu select Page Cache > General . Enable the following:
    Cache front page
    Cache feeds: site, categories, tags, comments
    Cache SSL (https) requests
    Don’t cache pages for logged in users
    Don’t cache pages for following user roles: Administrator, Editor, Author, Contributor and Subscriber.
    Scroll down : enable Cache alias hostnames
    If alias domains are used , undel Additional home URLs list all domains
    Navigate to Cache Preload tab enable Automatically prime the page cache.
    enable Preload the post cache upon publish events
    scroll down and enable Front page, Post page, Blog feed, Post comments pages and rss2 options from Purge Policy
    Navigate to Advanced tab and enable only Compatibility mode
    Save all settings
    navigate to Browser Cache menu and on General tab double check and make sure that the following options are enabled:
    Set last-Modified header
    Set expires header
    Set cache control header
    Set entity tag
    Set W3 Total cache header
    Enable HTTP gzip compression
    Enable the following options for CSS & JS, XTML & XML and Media & Other Files tabs as described below:
    Set last-Modified header
    Set expires header
    Set cache control header
    Cache Control policy set to cache with max-age and validation (“max-age=EXPIRES_SECONDS, public, must-revalidate, proxy-revalidate”)
    Set entity tag (ETag)
    Set W3 Total cache header
    Enable HTTP gzip compression

    Scroll down and click on Save all settings

    I hope this helps!

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @fadingmusic,

    Have you managed to resolve the issue? Please give us a feedback so you can close the topic and mark it as resolved.

    Best regards,

    Marko

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘htaccess file in self-hosted CDN’ is closed to new replies.