Support » Fixing WordPress » .htaccess file

  • Hi, so I am a bit of a novice, so I hope someone can help me.

    I am suddenly getting an Internal Server Error (quite common I think):
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, (suggested email) and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Here’s what I have done: googling told me that it might be a .htaccess file issue. so I have renamed the .htaccess via ftp and the error goes away (and wordpress tells me to make the file writeable)

    2.If I then navigate in the wordpress dashboard to settings/permalinks, wordpress will sometimes automatically rewrite a new .htaccess file and everything goes down again.

    3. I did have the http://url/sample-post/ permalink option selected, I have since changed it to no avail.

    4. I have looked at the content of the .htaccess file, the top half looks like my googling tells me it should look, but it is followed by # BEGIN HTML5 Boilerplate , and then a whole lot of text.

    5. also the only error_log file I can find via ftp is in the wp-admin folder and the content does not list any error during the time period I have been having errors.

    I am not sure what to do/try next. If I remove my rename of the .htaccess file I can’t work on my site, cant even log in.

    PLEASE HELP kind people!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Does anyone have any advice for me?

    Can you post your .htaccess contents?

    If it’s very large you can use

    hi yes.
    I used pastebin

    you will see the boilerplate content. I am not sure what is generating this part of the file. If I delete it, and wordpress rewrites a fresh htaccess file, the boilerplate text returns.

    thanks MickeyRoush, hope you can help.

    What version of Apache are you on? Depending on what you’re on the Boilerplate content is causing it. Usually the ifModules will prevent issues, but there’s a lot going on with it.

    What theme are you using?

    Thanks for your help so far.

    I am using the Pixia theme by Pirenko via
    I have 1 other plugin activated, Coming Soon Pro by Seedprod.

    I have to say I am in the dark when it comes to Apache. I am not sure how to check what I have, what I have access to or whether it has the mod_rewrite module.

    Overnight I was able to choose the default permalinks option, then rename the .htaccess file, then navigate in the dashboard away from the permalinks setting options page, then delete the boilerplate stuff from the htaccess file, and then remove the rename from the htaccess file. I can now continue building my site, but I’m sure the next time I try to set the permalink that I actually want, the issue will return.

    any ideas?

    If this happens every time you change permalinks and a new .htaccess file is set up, you should contact your hosting company and check that they support Apache mod_rewrite because if they don’t have Apache configured with that the directives will “break” the process, resulting in a 500 error like you’re getting.

    Thanks Michael Mariart, I did not think I could do the mod-rewrite without speaking to my hosting company, so that clears that part of it up for me. I will speak to them.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘.htaccess file’ is closed to new replies.