Support » Installing WordPress » htaccess doesn’t get created

  • JUst installed Wp for 1st time on IIS 5.0 / windows, host doesn’t provide modrewrite. Almost pretty permalinks don’t work and, investigating further, no .htaccess file is being created or modified EVEN though WP says “Permalink structure changed” and doesn’t spit out the code at the bottom of the page.

    Have tried creating 1.htaccess file with Notepad, uploading and renaming…I can still see it but when I click Properties/CHMOD I can’t change anything.

    Does this mean that something is wrong on the server? What? My host advises moving to Linux, but this seems a huge copout…

    thx Peter

Viewing 4 replies - 1 through 4 (of 4 total)
  • on IIS you won’t need an .htaccess file. It’ll never get used without mod_rewrite (or similar IIS compatible offerings)

    “Almost pretty” permalinks should work though, assuming your IIS server has been properly configured to looking for index.php as a default file.
    More on those at the Using_Permalinks page in the codex.

    I also advise you to move to Linux and make sure your host has the mod_rewrite Apache module

    Thanks Handy & arwen54…so I don’t need to worry about looking for .htaccess (the codex documentation suggests you will always have an .htacess….) I have tried the index.php permalinks, including the php.ini ( cgi.fix_pathinfo = 1
    cgi.force_redirect = 0) , but no luck…

    I can go on to try IIS’ custom 404 redirects or the other solutions mentioned in the codex.

    What are the advantages of using LINUX? (I have only ever run windows SW)?
    thanks Peter

    I’ve run WP on windows and linux. Primary difference? Permalinks work better 😉 (as you’ve noticed).

    You can search the forums & codex and find some pointers to 3rd party IIS options that might get it all working, but in the Linux world it generally “just works”.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘htaccess doesn’t get created’ is closed to new replies.