WordPress.org

Forums

All In One WP Security & Firewall
[resolved] .htaccess content after migrating site from localhost to server (6 posts)

  1. mhenschel
    Member
    Posted 1 year ago #

    Hi,
    I have set up my site on a localhost and then migrated the site to a web server. There are entries from AIOWPS, which now refer to my localhost.
    e.g. in
    #AIOWPS_BLOCK_SPAMBOTS_START
    RewriteCond %{HTTP_REFERER} ....
    RewriteRule ...
    Do I have to change those settings manually or is there a way that AIOWPS refreshes or renews those settings?

    Thanks Michael

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. mra13
    Member
    Plugin Author

    Posted 1 year ago #

    You can change them manually but that is not recommended (it will be easy to make a mistake if you try that approach).

    Go to the admin dashbard of the securtiy plugin. Deactivate the feature in question and save it. Then reactivate it, the plugin will re-write the htaccess file with correct URL values.

  3. mhenschel
    Member
    Posted 1 year ago #

    Which feature is writing the entries in #AIOWPS_BLOCK_SPAMBOTS_START?
    All features I disabled and enabled didn't change the localhost entry "RewriteRule .* http://127.0.0.1 [L]" in the section for #AIOWPS_BLOCK_SPAMBOTS_START in the htaccess file.

  4. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    That's in the SPAM menu and the feature is:
    Block Spambots From Posting Comments

  5. mhenschel
    Member
    Posted 1 year ago #

    Thanks for the support.

    The entry "RewriteRule .* http://127.0.0.1 [L]" stays the same after disabling and enabling Block Spambots From Posting Comments.
    But I don't have the knowledge anyway to judge if this is right or wrong. So maybe this is the correct entry.

    Michael

  6. wpsolutions
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Michael,
    Yes that's right this is the correct directive entry for that feature. (Basically the SPAMBOT is being redirected back to its localhost)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags