Support » Networking WordPress » htaccess change not taking effect.

  • Hello, everyone, I have a multisite where my sites are saving all media files, but they are not showing up and the path is different.

    The site settings are to save each upload to:
    wp-content/blogs.dir/#/files

    Instead, each media upload is calling sitename/files/year/month/filename

    I changed my .htaccess file to the following line under #Uploaded Files, but the files continue to go to the wrong page.

    What am I doing wrong? Do I need to restart something in WordPress or should the change take effect immediately?

    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /manage/
    RewriteRule ^index\.php$ - [L]
    
    #Uploaded Files
    RewriteRule ^([_0-9a-zA-Z-]+/)?siteN/files/(.+) wp-content/blogs.dir/N/files/$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . /manage/index.php [L]
    </IfModule>

    Thank you for your help in advance.
    Bruce

    • This topic was modified 1 year, 1 month ago by  hotwebideas.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    I have a weird feeling it could be the siteN. You may need to use the actual ID for the site rather than that. That was just a quick glance though. 🙂

    Thanks, Jose, if I have 20 sites in the network, then that solution would not be practical. The siteN just substitutes the site name from the database, not the site ID, but my problem is that I still cannot get the Media URL to be rewritten regardless of what is in the htaccess.

    Nobody has an answer?

    khushbu1983

    (@khushbu1983)

    Hi

    Which version of wordpress are you using.. This might be issue with older wordpress mu installation

    khushbu1983

    (@khushbu1983)

    You haven’t mentioned your site url earlier and then if you have changed it. There might be issue with uploading path in database.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘htaccess change not taking effect.’ is closed to new replies.