Support » Alpha/Beta/RC » .htaccess Blocking Real Directories

  • I’m having a bit of a problem with RC3. I upgraded from 1.5.3 and all is working fine except the new .htaccess funtion. It’s used differently (as I’m sure you know) now in 2.0 however they way it’s setup, it blocks real directories 🙁

    Example… I have my WP installed at http://www.gravityxzone.com and an image gallery installed at http://www.gravityxzone.com/gallery/ however now when I try to go to the gallery it just puts me at my blog homepage.

    Is there any way to fix this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • After making a test directory, it would seem that it’s blocking my Gallery directory because it’s password protected. So how do I fix that? I need that directory to be password protected.

    Moderator Ryan Boren

    (@ryan)

    WordPress Dev

    WP shouldn’t attempt to rewrite directories or files that exist in the filesystem. I’ll give it a look.

    I’ve tried redoing the htaccess file that password protects the gallery DIR, and redoing the WP htaccess through the admin interface and still nothing.

    Thanks for looking Ryan, I will check back in a bit to see if you came up with something.

    I’m not an Apache expert, but I’m guessing that Apache doesn’t detect a password protected directory as a directory for the RewriteCond -d flag.

    You could try putting the follow above the two RewriteCond’s that WordPress2 puts in.

    RewriteCond %{REQUEST_URI} !^/gallery/?$

    This will (should) tell Apache to process the next rewrite rule (the one that makes it look like the homepage) only if the request isn’t for your gallery directory.

    Thanks for the help Tollie, however I already just made the folder a sub domain instead. It’s the only real folder that I have (other than the WP directories of course) so it was easy enough that way and it works so I’m happy 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘.htaccess Blocking Real Directories’ is closed to new replies.