Support » Fixing WordPress » .htaccess and permalink problems

  • Resolved jimmerd


    Just did a new fresh install and everything worked fine as usual.

    Then went to change permalinks to my default:

    Which I do ALL the time.

    As soon as I clicked Save Options, the screen went into “no CSS” mode. That is: I got the Permalinks Options page, but with generic styling, none of the WP Dashboard look.

    Then went to the blog and got a 500 error.

    So I knew that the .htaccess file was probably the problem. Permissions? Fine. WP was able to write the file with no problem.

    So I uploaded the default .htaccess file and reloaded. Still 500 error.

    So I uploaded a BLANK .htaccess file. Blog homepage fine but got 404 errors for all other pages (which had apparently correct urls: /postname/. Dashboard fine. Clicked on Permalinks and immediately went back to the NO CSS mode. And the blog no longer worked.

    I’ve searched the Forum as fully as I can.


    a. How to fix this?

    b. Why is permalink-options.php re-writing .htaccess when I open page? I’d expect it to re-write it when I click “save options”.

    SQL for options table:
    INSERT INTO 'chichi_options' VALUES (31, 0, 'permalink_structure', '/%postname%/', 'yes');

    Thanks in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • jimmerd


    It appears my host may be running php4. The general settings say “The PHP Date/Time library is not supported by your web host.”

    And there are RSS feed widgets on the Dashboard homepage that aren’t working as normal.

    BUT: I did a phpinfo file and it indicates PHP 5.1.6

    Is that the problem? Codex says at least 5.2 is recommended.

    I have found that anything I put in an .htaccess file causes problems.



    I’ve seen issues with 1&1’s hosting running WordPress recently due to php5 being installed but php has been parsing your pages. To fix on 1&1 you need to add the below two lines to the very top of your htaccess file (using ftp). Try and see if it solves your issue. If it doesn’t then maybe try deleting your .htaccess file and generating it again from within WordPress on the permalinks page.

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php



    Resolution: Turns out the mod_rewrite was turned off, which support tells me is the default for their install. They turned it on and all is now fine.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘.htaccess and permalink problems’ is closed to new replies.