Support » Plugin: Really Simple SSL » htaccess

  • since latest version im having trouble with the code being put into the htaccess file, i have been using this for a while and its always worked great… but last few days there have been problems on every site i add it to

    • This topic was modified 2 years, 11 months ago by mike.s.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi Mike,

    Thanks for reporting this. I would like to resolve this issue, but can you tell me what the problem is you are having? I haven’t heard of any issues yet, but if you can give some input I can investigate.

    Hi

    when i activate the plugin it always adds some code into the htaccess.

    however for past few days this has not happened on all the sites i have activated it on… the sites are all on the same server as i normally use, so no changes there

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    could you show me a debug log of one of those sites?

    As of 2.5.0, I’ve adapted the curl check for the .htaccess redirect to verify the SSL connection. If that fails, the plugin can’t verify the .htaccess, and may not insert the redirect rule. Maybe when I see the debug log I can understand what is happening on your server.

    Maybe you can email me at rogier (at) really-simple-ssl.com some more details, like the domain, etc.

    Hi Rogier

    I just sent you details via email

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    So for any others running into this: if your server is not apache but is using .htaccess, you can add this to your wp-config.php to make the plugin run as if it’s on apache:

    define( 'RSSSL_SERVER_OVERRIDE' , 'apache');

    We’re experiencing this issue as well. We host our websites with Cloudways. They use Apache with NGINX as a reverse proxy. Something about the new .htaccess rule causes an infinite redirect loop.

    I tried adding that line of code to the wp-config.php, but it didn’t help

    I have been able to fix it by swapping out the new rule with the old rule:

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    • This reply was modified 2 years, 11 months ago by FaceLord.
    • This reply was modified 2 years, 11 months ago by FaceLord.
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi,

    Thanks for reporting this. This is slightly different, as in the other issue, which is solved as of 2.5.1, no .htaccess was inserted at all.

    In the latest version, if there are more .htaccess redirects that give back a valid response, they are added as well. This appears to cause a problem for your setup. Maybe the combination of conditions does not work well in your situation.

    Do you still have the redirect the latest version inserted? Would be good to see what is causing an issue for you.

    If have a version published on Github, that uses only the first working .htaccess redirect. To be able to provide a version that solves this issue, could you try if that version does work for you? You can download it here:
    https://github.com/rlankhorst/really-simple-ssl

    Any feedback would be very helpfull!

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    @facelord, most recent version, 2.5.3 only adds one .htaccess redirect condition. This should solve the issue. If you run into any issues with this, please let me know!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘htaccess’ is closed to new replies.