Support » Fixing WordPress » Howto enable Wulfilan characters in posts and pages?

  • Resolved sestir

    (@sestir)


    When I moved from http://yeihosbokos.wordpress.com to selfhosted http://weihos.eu, the pages cut off, like EOF, before the wulfilan character. Looking in phpMyAdmin, I can see that the remainder of the page’s content was not stored in the DB.

    A wulfilan character is part of the unicode that cannot be represented in a byte. For example a wulfilan A has code-point 0x00010330. Wulfilan characters is the second most common way to write Gothic, after latin transcription and Gothic is in turn one of the most widely spoken dead languages.

    I wonder if I should convert the database to something other than UTF-8, such as UTF-32. Or is there some much simpler solution like ‘install this plug-in’ or ‘change this setting’?
    Thanks great for your time!

    Edit: I should provide an example to show what happened. This is the beginning of John’s Gospel…
    http://www.weihos.eu/iohannes/
    … and this is what it should have looked like …
    https://yeihosbokos.wordpress.com/iohannes/

Viewing 1 replies (of 1 total)
  • The solution that eventually worked for me was to convert the database to ‘utf8mb4’. When MySQL talkes about ‘utf8’ they do not talk about UTF-8 despite the apparent similarities of the two names. That would have been too simple. ‘utf8’ is just 3*16 bits whereas UTF-8 fits into 4*16 bits.

    After converting the database and making sure the phpMyAdmin interface is set to communicate in utf8mb4, it is time to change the file wp-config.php in the home directory of the wordpress installation so that the charset-variable takes “utf8mb4” instead of “utf8” and then it works.

Viewing 1 replies (of 1 total)
  • The topic ‘Howto enable Wulfilan characters in posts and pages?’ is closed to new replies.