Support » Plugin: Wordfence Security - Firewall & Malware Scan » How to whitelist SGCache plugin

  • I have a SiteGround cloud server that hosts several sites. I use both Wordfence and SiteGround’s caching plugin in each of these sites. A few months ago, I noticed that the caching plugin was not working properly – I couldn’t interact with its settings and make changes. After a good bit of back and forth with Siteground support, we realized the Wordfence installation in the base site was affecting the plugin in sub-sites. During this process, I set up a super simple install with no additional plugins and a base theme for simpler testing.

    Siteground support’s conclusion was:

    The issue is caused by WordFence blocking a specific request that is required to make the check for the PHP version and the scripts to trigger :

    Code:
    https://subdomain.base-domain.com/index.php?rest_route=/siteground-optimizer/v1/fetch-options

    403 Forbidden
    A potentially unsafe operation has been detected in your request to this site.

    Generated by Wordfence at Fri, 24 Jan 2020 23:25:14 GMT.
    Your computer’s time: Fri, 24 Jan 2020 23:25:16 GMT.

    Since that URI is not allowed to pass, this causes the issue in the first place. Please make sure to whitelist the requests towards the URL in the WordFence Firewall settings to avoid the call from being blocked, which will take care of the issue at hand.

    It’s worth noting that Wordfence is not installed for this subdomain, and if I disable Wordfence in the base site, all is fine. Unfortunately, Siteground is unable to help me whitelist this query. My hope is there is a way to structure it with a wildcard, so that I don’t have to add an entry for every subsite.

    How should the whitelist entry be structured?

    • This topic was modified 2 years, 4 months ago by heytricia.
    • This topic was modified 2 years, 4 months ago by heytricia.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hey @tendigit,

    My apologies for the delayed response.

    It sounds like it’s triggering a Firewall rule. Can you please switch the Firewall into Learning Mode and let me know if it helps?

    https://www.wordfence.com/help/firewall/learning-mode/

    Please let me know how it goes.

    Thanks,

    Gerroald

    Thread Starter heytricia

    (@tendigit)

    That does seem to have addressed the problem. Now that learning mode time has expired, I am still able to work with SG Optimizer in the sub-site.

    So does this mean we’ll have to go through these steps every time we add a new subsite?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to whitelist SGCache plugin’ is closed to new replies.