Support » Plugin: Wordfence Security - Firewall & Malware Scan » How to whitelist AWS?

  • Resolved parakeet


    I need to connect another service to my WordPress via xmlrpc.php.

    However, I have disabled all xmlrpc.php in Wordfence.

    Currently, the service is failing to connect with error 503.

    The service uses rotating IPs via Amazon Web Services. I need to whitelist all of its us-east-1 IPs. I know these are made available at

    However, when I paste the IPs in to the box “Whitelisted IP addresses that bypass all rules”, still the service is blocked. Heck, even when I find the IP in Live Traffic and unblock it, it still gets blocked next time.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi @parakeet,

    Have you re-enabled xmlrpc.php? If not, could you re-enable and retest whether the IPs are still failing to connect to the service?

    Presuming you mean “remove ‘/xmlrpc.php’ from the textarea for ‘Immediately block IPs that access these URLs'”…

    I just removed that and saved options…

    Yes, the service, which is Zapier, connects when I do that.

    When I put “/xmlrpc.php” back in the box…
    The first connection succeeded.
    The second failed.
    The third failed.

    First may have been using an IP range that remains in the “Whitelisted IP addresses that bypass all rules” textarea, “”. Zapier rotates its AWS IP usage.

    It may help if I was more certain about how exactly to whitelist the AWS IPs.
    Amazon’s own list is JSON, which doesn’t make it easy to copy and paste from.

    Not sure if I’m doing something else wrong, though.

    Hi @parakeet,

    If you leave xmlrpc.php in place for Immediately block IPs that access these URLs, then any requests that leverage xmlrpc.php will in fact be blocked regardless of whether or not you have the IP addresses otherwise whitelisted.

    The initial success may have been due to an existing connection that was still open at the time you rechecked the connection, but the second and third failures would be the expected behavior when xmlrpc is blocked. Unless you have a need to keep xmlrpc.php blocked, in which case you won’t be able to use Zapier or any other external service that uses xmlrpc, you should go ahead and remove it from the block list.

    Let me know if you have any further questions!

    Since xmlrpc.php is a known exploit channel, and I have seen traffic attempt to use it, I like the sound of blocking this access.

    But I assumed whitelist could override that for predefined IPs, so I’m surprised.

    I wonder if I can use .htaccss to block xmlrpc.php access for all except stated IPs, using this method. If so, I assume I would have to remove it first from Wordfence to allow .htaccess to take effect… ?

    Sounds like it should have the intended effect, but I would lose Wordfence’s extra abilities like blocking upon detection of traffic to that URL… ?

    Hi @parakeet,

    I discussed your use case with the team, and the general recommendation is that you remove xmlrpc.php from the “access these URLs” block, as xmlrpc.php is protected by the brute force protection rules that also protect the login page. However, if you want to proceed with having xmlrpc.php explicitly blocked, you can do so and then go to Firewall > Firewall Options > Advanced Firewall Options and enter the AWS IPs to whitelist in the “Whitelisted IP addresses that bypass all rules” field. You will need to keep in mind that the AWS IP addresses listed in that json file can change, so you will need to keep that in mind when troubleshooting external service issues.

    Let us know if you have any further questions!

    Hi @parakeet,

    After doing some retesting, it looks like your original configuration should be working. If you’re taking the IP address ranges straight from the JSON file, they’re not going to work as the IPv6 addresses need to be formatted to match what is required by the parser:

    Ah this may be the issue.
    I’m going to try it and reply to update.

    Current state of play…

    I went back to Amazon’s list of IP ranges

    Being in JSON, it is unworkable to paste them in to Wordfence’s whitelist list.
    I bit the bullet…
    Added ImportJSON to Google Sheets, so as to display Amazon’s list in a sheet, then I was able to view only the us-east ones, in a column.
    I copy-pasted those in to Wordfence’s whitelist list, and saved…

    As of now, I am getting repeating success trying to connect Zapier to my WordPress.

    We’ll see if their IP rotation is stuck or something, but it looks good.

    We’ll also see if this is too liberal and dangerous.
    But I think you already confirmed that Wordfence will effectively backstop xmlrpc.php protection by banning repeating failed authentication attempts by xmlrpc.php? Because access via that method relies on successfully authenticating, does it?


    Hi @parakeet,

    Glad to see that you’re getting successful connections!

    That’s correct — brute force protection will also protect xmlrpc.php, plus you have the other options for whitelisting the IPs with an explicit block.

    Let us know if you have any further questions or concerns!

    I wanted to revive this since Wordfence appears still to be blocking Zapier for me. I do not have xmlrpc.php in “Immediately block…” and haven’t added all those IPs to the whitelist (which seems improperly open). Can the team take another look at this issue or perhaps suggest where I’m going wrong?



    Hello there – same here: having issues with Zapier and IFTTT and xmlrpc after a recent update of Wordfence. Wondering what is the solution other than importing the (rotating) IP list into Wordfence? thanks



    For reference, I’m getting error 405 – XML-RPC service is disable on website from both Zapier and IFTTT. I’m unable to reconnect either service.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘How to whitelist AWS?’ is closed to new replies.