The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] How to upgrade again? (6 posts)

  1. Filostoof
    Posted 9 years ago #

    I have the category and blogroll problem as seen as below (the message I get within writing a post:

    WordPress database error: [Unknown column 'link_count' in 'where clause']
    SELECT cat_ID FROM wp_categories WHERE category_parent = 0 AND ( link_count = 0 OR category_count != 0 OR ( link_count = 0 AND category_count = 0 ) ) ORDER BY category_count DESC

    I had some trouble with the upgrade, it gave me database errors that I did not have enough right. I mailed my webmaster and he said he fixes my rights. I'm trying to upgrade again, (uploaded al the files etc.) When clicking the upgrade button, it gives no errors anymore, but it seems he is not doing the sql upgrade anymore in this process.

    Do you have a way for me I can upgrade the database with the new 2.1 tables? Or do I have to alter some key in the database where it thinks I did not already updated the thing?

  2. Samuel B

    Posted 9 years ago #

    Are you getting this message in your admin or on your page?
    Be sure all plugins are disabled before upgrading - especially stats plugins.
    If the upgrade completed you should see 2.1 at the bottom of any of your admin pages.

  3. Filostoof
    Posted 9 years ago #

    It is 2.1 allright, it says in the button

    This message is in the adminscreen when I try to write a post.

    The first try to upgrade gave my errormessages that wordpress had no rights to alter some tables. I have those rights now, but when I re-upload all the files, it seems he does not upgrade anymore, (he probably thinks he did it already)

    Al works perfect, except for the links en category thing, I read more of those errors.

    I think the solution for me is to manually update the database, with the commands that the upgrade should give, but I dont know what those queries are, or how to force that?

  4. It might be best to simply restore your database from your backup and try the upgrade again.

  5. Filostoof
    Posted 9 years ago #

    I am so scared to do that... :(

    But when its the only option I just have to I guess ...

  6. Filostoof
    Posted 9 years ago #

    It worked!

    I restored my back up database and now it works ok. Thanks for the help

Topic Closed

This topic has been closed to new replies.

About this Topic