Support » Themes and Templates » How to update to PHP 7

  • jcbsep

    (@jcbsep)


    Hi again team!

    I can’t activate a plugin because my version of PHP is outdated (5.3.3-7+squeeze14).

    Does someone know how I could update it?

    Thank you in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator stephencottontail

    (@stephencottontail)

    This isn’t really a WordPress issue; have you spoken to your hosting provider?

    jcbsep

    (@jcbsep)

    Thanks for your answer @stephencottontail

    Yes, I did. They told me that I might have issues with the PHP 7 version and I should make sure that all my websites are compatible with that version of PHP.

    The main problem is that I don´t know how to check if my websites will or won’t be compatible with PHP 7.

    Some ideas?

    Thanks again!

    Moderator stephencottontail

    (@stephencottontail)

    WordPress core itself is compatible with PHP7. I found this plugin that performs automated compatibility tests (https://wordpress.org/plugins/php-compatibility-checker/) but it’s not 100% guaranteed. Your best bet would be to ask your theme and plugin authors if they know of any issues with PHP 7.

    Thank you so much @stephencottontail !

    I will do both!

    🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘How to update to PHP 7’ is closed to new replies.