Support » Fixing WordPress » How to turn off no-cache headers

  • aCstudent

    (@acstudent)


    I moved a site to a new host – it is working but slow. Does not seem be cached even though I setup both litespeed cache and a CloudFlare cache-everything page rule. Looking at the headers in Chrome developer tools, I see these:
    cache-control: no-store, no-cache, must-revalidate
    pragma: no-cache
    cache-control: max-age=0

    This turns off caching, right? I certainly did not mean to do that but I may very well have done something dunderheaded that caused it. Any advice how I can correct this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator bcworkz

    (@bcworkz)

    Try logging out of WP and checking headers and caching again šŸ™‚ WP rightfully sends no-cache with logged in users, otherwise editing would be extremely frustrating.

    If you still have trouble, there could be .htaccess rules sending headers that defeat caching.

    aCstudent

    (@acstudent)

    Thanks for responding bcworkz. I am nearly certain I was not logged into WP when checking the headers – but will check again to be sure. I checked htaccess – this is a new install so nothing there but the bare-bones stuff that WP and litespeed cache put in – did not see anything to do with no-cache headers.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘How to turn off no-cache headers’ is closed to new replies.