WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] How to turn off comments?

[Resolved] How to turn off comments?

  • http://animationnexus.com/

    I know going to Options can help stop people from making comments but how do you just turn the features off? Notice it has “Posted in News | No Comments ยป”? Well how do I stop the words No Comments from showing up? This seems like something that should be standard.

Viewing 9 replies - 1 through 9 (of 9 total)
  • http://codex.wordpress.org/Template_Tags/comments_popup_link

    Remove that template tag from your templates.

    I don’t have that template in my theme ๐Ÿ™

    If I were you I’d start with opening the index.php, archive.php, single.php, etc. and ‘control+F’ for “comments” and try to remove the code. It’s an anoying job (I tried to do the same with RSS and trackback links), since these commands are everywere. You try to leave out something that WP REALLY wants to be there.
    Good luck.

    Thanks Gangleri, I think my brain needs a rest from the internet and tv because I didn’t even think to look in my index.php

    Btw can I ask an extra question? What in the world is this? “|” It looks like a capital i (I) but it isn’t and I can’t find it on my keyboard, how do you make it without copying and pasting it from somewhere else?

    ON my keyboard is on the right end, same key as \ and it works with Shift. BTW, it looks like two little vertical lines, one above the other.

    Ok, I see it. On my keyboard it looks like two little lines standing vertically but when you type it in, it makes a line.

    woow thanks people i was looking for this to nice one..

    I spent almost two hours in 2.6.1 (installed via cPanel) looking for how to turn off comments globally, and finally found this:

    http://mydomain.com/blog/wp-admin/options-discussion.php
    Comments > Settings > Discussion
    and on that page, unchecked
    [ ] Allow people to post comments on the article
    … and [Save Changes] at the bottom

    … but then my one test message still allowed comments, and finally figured out to access it (as if I wanted to edit the message), scroll to the bottom, open up Comments & Pings, and turn of comments for that page.

    Sigh …

    The | character is called a ‘pipe’.

    I also want to be able to turn off comments ENTIRELY without there even being a ‘No Comments’. It’s pretty silly that editing the raw index file is required for that.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] How to turn off comments?’ is closed to new replies.