Support » Plugin: Contextual Related Posts » How to tune – keeps showing the same handful of posts

  • Hi,

    I’ve set up the plugin in our staging environment, and it keeps showing the same 3-5 posts, regardless of the post viewed. There are over 800 posts on the site, and there are more relevant posts that could be featured.

    How do you recommend we adjust the settings to better tune the post lists?
    I tested enabling the “Cache posts only” feature, and the “Related posts based on title and content” option, and it did not make a significant difference.


    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ajay


    What is your site URL I can observe this?

    Hi @ajay, unfortunately you can’t view the URL, as it is in a password-protected staging environment. The production environment will be on, but we have not pushed the plugin because we need to do some styling and get the results list to be better tuned to the content.

    Do you have any recommendations on how to modify the settings to get more relevant results? For example, should we include our categories as a limitation? Not sure if that will work, since I believe we use custom categories.

    Thanks for your help.

    Plugin Author Ajay


    If you’re in a staging, can you try a couple of things:

    1. Check you have a proper fulltext index – you can check this in phpMyAdmin
    2. Install Query Monitor and see the query generated by the plugin – see if there are any errors in the queries
    3. Another thing to try is to install the crp-taxonomy addon which allows you to limit by categories and/or tags as well as disable the fulltext matching



    I am having the same issue. It keep pulling the same 4-6 posts, even though there are other posts that match much better (tags and categories). I have had to do manual post IDs many times.

    My site is

    Plugin Author Ajay



    Were you able to try the above steps?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.