Support » Plugin: WP-Optimize - Clean, Compress, Cache. » How To Totally Disable Compression?

  • Resolved slangs


    I can see where Cache is disabled and the Optimize part is set to manual, but there doesn’t seem to be a switch to disable Image Compression, which I do not want to use.

    Please advise if this is possible.

Viewing 10 replies - 1 through 10 (of 10 total)
  • In the back-end, go to WP-Optimize -> Images. The very first line says…

    Automatically compress newly-added images.

    Turn it off. 🙂

    I know that option for new images, but when I go to create a new post, I still get the options showing up in Media.

    Are you saying that by disabling “Automatically compress newly-added images” this switch disables 100% of the Compress functionality and there is 0% chance of compressing any image on the site?

    I ask because the options are still there when adding old images to new content.

    • This reply was modified 10 months, 2 weeks ago by slangs.
    • This reply was modified 10 months, 2 weeks ago by slangs.
    Plugin Support Marc Lacroix


    Hi @slango

    Like @ocbroadband says, disabling that option will prevent new images from being compressed. To disable the options on the media modal and pages, disable the second option “Show compression meta-box on an image’s dashboard media page”.

    The compress functionality will then only be available in the wp-optimize options.

    Thanks, and I’ve already done that but call me paranoid but it doesn’t seem to be “off”, but I guess that’s the highest level of disabling,

    Plugin Support Marc Lacroix


    Do you still see the options in other places than on WP-Optimize? It shouldn’t be the case.


    Can this be related to my other post regarding the settings being retained?

    Plugin Support Marc Lacroix


    @ocbroadband No that’s a different issue. The settings being retained between the 2 screens isn’t included yet in the code, while the option to show or hide the compression options on the media screens has been there for some time now.

    Plugin Support Marc Lacroix


    @slango feel free to share screenshots of your WP-Optimize settings as well as media modal.

    If indeed it is showing, there could be an error somewhere preventing the option from saving.

    Thanks and I have it deactivated for now, but I will be testing late tonight and will update the thread with needed data.

    Plugin Support bcrodua



    As we have not heard back from you for 2 weeks now. We will close this thread and please feel free to open a new one.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘How To Totally Disable Compression?’ is closed to new replies.