• Resolved demonboy

    (@demonboy)


    Hi,

    Love the plugin so far, it’s very intuitive and clean to use. I do have one issue though, and that is that a pop-up is appearing on a page it is not supposed to because I have a slider on that page instead, and I can’t test it because the pop-up has already run once.

    On the main pop-up I have set conditions to not display on a certain URL. Instead, that URL has a slider. When I first checked that page the pop-up appeared, not the slider, despite the conditions telling it not to do so.

    And now that I’ve checked it once, it won’t run anymore because I set it to only show once every 21 days. I have cleared the cookies from three different browsers but I can’t get it to run again.

    Is there a test mode? I see there is a debug mode – is that the same? I don’t want to have to change the conditions of the popup in order to test it because that’s a short-cut.

    Any assistance is appreciated, thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Zafer – WPMU DEV Support

    (@wpmudevsupport15)

    Hi @demonboy,

    You can use incognito mode in your browser to test it.

    The easiest way to open an Incognito window for Chrome is with the keyboard shortcut combination Ctrl-Shift-N (Windows) or Command-Shift-N (macOS).

    Kind regards,
    Zafer

    Thread Starter demonboy

    (@demonboy)

    Hi Zafer,

    Yes, of course, Incognito! Doh!

    However, this slide-in is still not displaying. To be on the safe side I have removed all parameters that may cause issues, so nothing depending on cookies. I have it set up as:

    Unticked ‘never see this again’
    Unticked ‘automated email’
    Left all appearance options as ‘default’
    Only display on a specific URL, that is – Show when All of the following conditions match Specific URL Only these URLs
    Display immediate
    Close when user clicks on X

    The only other form I have is a pop-up, and I have set that to NOT display on /pub/. That seems to be working, as in it is not displaying on /pub/

    Another test I did was to try a different page. Once again I set the slider to only show on this page immediately and set the pop-up to not appear on this page. When I check the page, however, the pop-up is displaying, not the slider.

    I run a cache plugin but I’ve purged all cache before each attempt and of course Incognito ignores cache anyway.

    There was an issue I was having when trying to display the slider on a specific PAGE (as opposed to URL). When selecting the page option a drop-down box appears with pages that match your search criteria. It would not allow me to put in /pub/, the name of the page I want to insert the slider into. Instead, it came up with /published-work/, another active page on my site.

    Any pointers? TIA

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @demonboy

    Thanks for response!

    I’ve visited that “/pub” page and I’m actually not quite sure now if this really is a “conditions” issue or rather issue with the page itself. Whatever condition is – even if it works fine itself, the plugin must still be able to correctly inject its HTML into the page, enqueue its scripts and run them (and they must run correctly).

    If you take a closer look at the page source of this page you’ll notice it seems quite “off”. Some of the basic issues: multiple “meta” and “link” tags inside the “body” part instead of “head”, a repeated DOCTYPE declaration in the middle of the markup and actually… pretty much another page markup starting with a regular “html” opening tag “out of the blue” in the middle of source…

    I’m not saying this is the cause for sure as I don’t really even have a way to test this kind of page source with Hustle but I’m wondering how this is all rendered and what causes the page source to be “mixed up” like this. It seems it may be related in some way to the PWA – I’m guessing you are using some plugin for this, right?

    Have you tried to disable it temporarily? If not, could you try then clear all caches again and see if Hustle works or, at least, if the page source starts too look more “proper”?

    I think it’s worth checking in this case…

    Best regards,
    Adam

    Thread Starter demonboy

    (@demonboy)

    Thank you for getting back to me and pointing this out, Adam. I was unaware of these errors! I’ll look into it and get back to you.

    Thanks once again.

    Thread Starter demonboy

    (@demonboy)

    Hi again, Adam. I’m not sure what the excess code is but I have rebuilt the page and stripped out some messy CSS. The two DOCTYPE declarations are still there but the slide-in is now working, so I’m pretty stoked, thanks!

    Keep up the great work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.