Support » Fixing WordPress » How to stop wordpress from creating thumbnail

  • anluu

    (@anluu)


    I try to save my server diskspace by stop wordpress from creating thumbnail when upload an image,

    Set thumbnail size to zero in Setting>Media

    Add these snipped to my functions.php
    add_filter(‘intermediate_image_sizes_advanced’,’stop_thumbs’);
    function stop_thumbs($sizes){

    unset( $sizes[‘thumbnail’]);
    unset( $sizes[‘medium’]);
    unset( $sizes[‘large’]);
    unset( $sizes[‘post-thumbnail’]);
    return $sizes;
    }

    It doesn’t show thumbnail option when upload but still creating other files with different size in host.

    Thanks for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    (@esmi)

    Set thumbnail size to zero in Setting>Media

    Wrong approach. Try setting dimensions that are very large.

    anluu

    (@anluu)

    It’s make sense, but it doesn’t work. 🙁

    esmi

    (@esmi)

    What dimensions are you using now?

    anluu

    (@anluu)

    I set value to 9999×9999 for all, but it create 150px-150px, 300px-300px,..

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘How to stop wordpress from creating thumbnail’ is closed to new replies.