WordPress.org

Forums

WP Editor
How to stop the double-space indent when adding a new line (10 posts)

  1. GermanKiwi
    Member
    Posted 1 year ago #

    Hi, when I'm editing a post/page and I'm on the Text tab, therefore with the WP Editor color scheme being used, and I hit Enter at the end of a line, the new line that is inserted underneath has two space characters at the beginning - kind of like a small indent.

    Can I disable these two space characters from being inserted like that? I find it quite annoying, as most of the time I don't need or want an indent when I hit Enter (and if I did, I'd just add the indent myself manually).

    http://wordpress.org/plugins/wp-editor/

  2. benjaminprojas
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    I would suggest setting the Tab Size to 0, but it looks like this doesn't work as expected. I am going to further troubleshoot to see what is causing this. This will have to wait until the next release of WP Editor.

  3. GermanKiwi
    Member
    Posted 1 year ago #

    Yeah I tried changing the Tab Size too, but with no luck.

    Thanks for looking into this!

  4. GermanKiwi
    Member
    Posted 1 year ago #

    Hi Benjamin, I've just updated to WP Editor 1.2.4, and it looks like the problem still exists with the two space characters being inserted when I hit enter.

    Are you able to find a solution to this? I still find it super annoying when I'm editing HTML code and have to always backspace to remove those extra spaces! :)

  5. benjaminprojas
    Member
    Plugin Author

    Posted 1 year ago #

    GermanKiwi,

    We will be pushing out a fix in the next update of WP Editor.

  6. GermanKiwi
    Member
    Posted 1 year ago #

    Awesome, thanks!

  7. benjaminprojas
    Member
    Plugin Author

    Posted 1 year ago #

    This has been fixed in the latest version of WP Editor 1.2.5.

  8. goferit
    Member
    Posted 10 months ago #

    Currently experiencing this problem with 1.2.5.1. Running Genesis with the following settings:

    https://www.dropbox.com/s/pdym2t4prcztmp3/Screenshot%202014-07-16%2012.38.46.png

    Also, is there a way to disable automatic indentation?

    Prefer no indentation, I tab to create indents where I prefer.

    Love the visual aspect but my backspace finger is about to fall off! ;)

  9. GermanKiwi
    Member
    Posted 10 months ago #

    Yeah I'm also still experiencing this problem, in spite of the changes with 1.2.5.

    @benjaminprojas could you kindly look into this issue for us again please? It's certainly annoying to always have to backspace to remove those indentations all the time! :)

  10. ghostbit
    Member
    Posted 6 months ago #

    Try: var indentUnit = 0; on line 2 of:
    ./extensions/codemirror/js/xml.js file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.