Support » Plugin: WP Post to PDF Enhanced » How to stop PDF files and the PDF icon from getting indexed?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Lewis Rosenthal

    (@lewisr)

    Hi…

    This is well beyond the scope of this project. I would suggest adding:

    IndexIgnore *

    to the top of your .htaccess file in your /uploads/wp-post-to-pdf-enhanced-cache directory. As for the icon, you may do the same thing in the assets/images directory for the plugin, if you like. I’m just not seeing a major advantage, but then, I’m not an SEO guy.

    Cheers

    Thanks for your quick reply. The problem is called duplicate content. I bet SEO guys would love this option. I’m not the Fiddling with the .htaccess file guy. 😉

    Alter, use in the cache directory the following .htaccess file to prevent PDF google indexing.

    <FilesMatch “.pdf$”>
    Header set X-Robots-Tag “noindex, noarchive, nosnippet”
    </FilesMatch>

    As for the PDF Icon, you can not prevent google to index parts of a page, and the PDF icon is part of the page.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to stop PDF files and the PDF icon from getting indexed?’ is closed to new replies.