Support » Plugin: Polylang » How to stop menu from changing language on blog?

  • Hi.

    I have three languages: French, Germany and English.

    I want to use -1- blog for all of them.

    But if someone who is on French language click on blog, menu changes to English.

    If someone who is on German language and click on blog, menu changes to German.

    How can I fix this so that the blog page does not change the menu language?

    Thank you. Forever grateful for any help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • i report same problem..

    It is not possible.
    The idea behind Polylang is to provide content in different languages.
    If you are on a German page the menu is German. English content, english menu, and so on. This is how it works.

    It’s not a problem, it’s a feature!

    yes, but in my case im spanish and my web has been translated to for example sweeden

    When edit de page elementor page builder options are translated to Swedish and i understand nothing 🙁

    My user has defined spanish language…

    • This reply was modified 2 years, 4 months ago by alfredo49.

    @codestylist

    Is it not possible to disable this for the blog page only somehow? Thanks by the way!

    Anyone have any suggestions for workarounds? Surely there must be a way to not translate certain pages?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘How to stop menu from changing language on blog?’ is closed to new replies.