WordPress.org

Ready to get started?Download WordPress

Forums

How to solve WAMP localhost 500 internal error (11 posts)

  1. moaa
    Member
    Posted 2 years ago #

    Hi I am trying to setup multisite on a local pc. Using Andrea Rennick's great ebook I setup multisite on my pc:
    - changed Permalink to pretty to activate .htaccess
    - added define('WP_ALLOW_MULTISITE', true); to my wp-config
    -created blog.dir in wp-content
    -added the following to wp-config

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/wp/';
    define( 'DOMAIN_CURRENT_SITE', 'localhost' );
    define( 'PATH_CURRENT_SITE', '/wp/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Then replaced .htaccess rules with:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Now when I click on Login, I get Internal Server Error

    The server encountered an "500 internal error or misconfiguration and was unable to complete your request."

    What else should I do to make it work? Please note I'm running wamp on local pc using subdirectory option
    thank you in advance

  2. Dang, I'm really gonna have to steal my kid's laptop one of these days.. it's the only Windows machine in the box.

    Basically Wamp is not set up right. Did you check those pretty permalinks before you set up multisite?

    Go to the default about page off the first blog. does it work?

  3. moaa
    Member
    Posted 2 years ago #

    Hi Andrea,
    I can't access the wp at all the 500 error is blocking me.

    my permalink is setup as : /%year%/%monthnum%/%postname%
    This is what I use for all wp sites I setup.

  4. Whack the .htaccess and see if you can get in.

  5. biotox
    Member
    Posted 2 years ago #

    I have the exact same problem. I killed the .htaccess and tested the default "sample page" but it gave me the 404-Not Found.

  6. biotox you need to set your permalinks to ugly. I was telling moaa that to get IN, since he was blocked, he should try removing the .htaccess to see if that let him in.

  7. biotox
    Member
    Posted 2 years ago #

    I found a solution for WAMP users. They unusually need to enable the mod_rewrite for their Apache server. In the httpd.conf find "LoadModule rewrite_module modules/mod_rewrite.so" and remove the pound (#) from the beginning of the site. Save the file and restart WAMP. Add the .htaccess file changes for the WordPress network. Refresh and it should work.

    From what I read, some need to change AllowOverride none in the httpd.conf to AllowOverride all as well. I hope this helps.

  8. bg_1
    Member
    Posted 2 years ago #

    biotox, thank you for your advice. I have removed the pound sign and I'm in!

  9. bazzablue
    Member
    Posted 1 year ago #

    I stumbled on this thread because I was having the 500 internal error problem. Removing the .htaccess file solved this problem but it leaves me not able to view the sub site I have created.

    I am using WAMP at present. I have tried locating httpd.conf but without success.

    Any help would be greatly appreciated.

  10. bazzablue
    Member
    Posted 1 year ago #

    I have located httpd.conf and made the changes recommended by biotox. The only thing that changed is that when I click on 'Visit' for the sub site I get a Server Configuration page.

  11. bazzablue - We now have a dedicated localhost subforum where they can help you: http://wordpress.org/support/forum/localhost-installs

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.