Support » Plugin: Google Analytics Dashboard Plugin for WordPress by Analytify » How to Solve “OpenSSL SSL_read: Success” error

  • Plugin Author Adnan

    (@hiddenpearls)


    Hi, @all

    If you are having this error “OpenSSL SSL_read: Success” and stats are not appearing on your Analytify Dashboards, please read below.

    We have seen that the cURL version (curl-7.67.0) that installed in your Server OS was not supported by official application repositories. According to their website https://curl.haxx.se/download.html cURL version (curl-7.67.0) is a stable version but not for all operating systems yet. It seems that cURL version (curl-7.67.0) was manually installed on your servers.

    Stable version according to OS

    Centos8 = curl-7.61.1-8.el8.x86_64.rpm
    Centos7 = curl-7.29.0-54.el7.x86_64.rpm
    Debain10 = curl_7.64.0-4_amd64.deb
    Debain09 = curl_7.52.1-5+deb9u9_amd64.deb
    Ubuntu 18.04 = curl_7.58.0-2ubuntu3_amd64.deb
    Ubuntu 16.0.4 = curl_7.47.0-1ubuntu2_amd64.deb

    In our debugging process, We downgraded to cURL version (curl-7.66.0) or other stable versions according to your server OS and It worked fine. I highly recommend to ask your webhosts or sysadmins to downgrade the cURL version (curl-7.67.0) to cURL version (curl-7.66.0) should make the Analytify work again.

    P.S We are also working on our code to make it work with even unstable version of cURL but until then use the above solution, please.

    Thanks.

    • This topic was modified 1 year, 5 months ago by Adnan.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • I’m on a shared host and can’t downgrade cURL.

    When is a new working version of Analytify available? Or can I better switch to MonsterInsights?

    Kind regards, Gerske

    No news about a new Analytify version than can work with the new cURL version?

    Plugin Support Asad Shahbaz

    (@artisticasad)

    Hi,

    We have beta version ready for testing.

    Please contact us via our support form within Analytify’s help tab so we can provide it to you.

    Looking forward.

    My Cpanel says I have 7.3.16-2.2.1.cpanel installed. I don’t see any options for downgrading. And Analytify worked just fine a day or two ago, it’s only broken in the last 24 hours. Why would it work before and not now?

    My solution was uninstalling Analytify, because there is no fix from them.

    Any news on this? I just realized this post was started 4 months ago.

    Well, I have all my client sites on one server so I know it’s not a server issue because it works on some sites but not all. I assume it must be a plugin conflict of some kind.

    capabomba

    (@capabomba)

    Yes, how come there hasn’t been any update on this issue after 4 months?

    cim

    (@cim)

    I will have to abandon this plugin and find an alternative as there has been no replies or attempts to fix it. Also it won’t let you authenticate with Google anymore.

    • This reply was modified 1 year ago by cim.

    Is there a reason why the developers are not giving any more comment on this? It is a weird behavior if you ask me…

    It has been a long time since any option other than downgrade has been suggested.

    I am on a shared host and the hosting company is not interested in downgrading just to satisfy me.

    A solution that has been wanting for 9 months would be appreciated.

    At least we would like to know if you are even working on it. In the meantime I couldn’t do anything else but drop your plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘How to Solve “OpenSSL SSL_read: Success” error’ is closed to new replies.