Support » Fixing WordPress » How to Solve : Jetpack HTTP 403 Error

  • I was installed and activated Jetpack on www.wppersian.com, in my Previous host.
    After I Transfered my it into new host . Jetpack Gives this Error message.

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible
    The Jetpack server was unable to communicate with your site [HTTP 403].
    Ask your web host if they allow connections from WordPress.com.
    If you need further assistance, contact Jetpack Support: http://jetpack.me/support/

    My XMLRPC Address is : www.wppersian.com/xmlrpc.php

    Anyone Could Help me ,Please?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    http://www.wppersian.com/xmlrpc.php is blocked, and Jetpack requires access to this file to function.

    Unfortunately, blocking XML-RPC is not a great solution for fighting security risks. It’s akin to selling your car because you don’t want it to be stolen.

    Your site’s XML-RPC file is kind of like a communication gateway to your site. Jetpack, the WordPress Mobile Apps, and other plugins and services will use this file to communicate to your site. If this is blocked, you will have other issues pop-up down the road for the same reasons.

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s XML-RPC. The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with your WordPress.

    If they refuse to make any changes, and if you want to use apps and plugins like Jetpack, I’d suggest looking for a new host. There is one recommendation at https://wordpress.org/hosting/ with more coming soon.

    Ok
    Thank You so much.
    I’ll go to try your guidance.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    You’re welcome!

    Jetpack has been working fine for years now. Today, I just deactivated all plugins to troubleshoot an unrelated problem and when I reactivated them Jetpack started to throw this error. Of course, no settings have been altered in the few minutes between deactivation and reactivation. Where could that problem now possibly lie?

    @brembs: same here. did you find a solution yet?

    @paulcalcus: Yes, I looked through all relevant .htaccess files and found an offensive entry. It seemed as if it had been there all the time, but apparently without any effect until I de-activated and re-activated Jetpack. Curiously, the entry was added by a security plugin, where I explicitly clicked on a button to allow for XMLRPC. After I commented the entry out, Jetpack stopped complaining and the security plug-in showed no change in behavior.
    <shrug>

    This might be useful for anyone with the same problem: I found that xmlrpc.php had been blocked in the .htaccess file, so I removed the <Files xmlrpc.php>….</Files> lines. Still no good. I discovered that with my host, just removing the block didn’t work – it seems that once blocked. the server caches this behaviour. Access to xmlrpc had to be explicitly allowed, like this:

    <Files xmlrpc.php>
    order allow,deny
    allow from all
    </Files>

    Even then I still got the error message, but Jetpack connects fine and once closed, the message doesn’t re-appear. Hope this helps someone avoid a wasted morning (like I just had trying to figure this out).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How to Solve : Jetpack HTTP 403 Error’ is closed to new replies.