WordPress.org

Forums

Virtue
[resolved] How to show active Tab in the main Nav-Bar (24 posts)

  1. shaunvine
    Member
    Posted 2 years ago #

    Does anyone know what the custom CSS code is that will show the active Tab in the Main Menu? I would like to remove the page headings. The design would be a lot cleaner if the page that is active would show in the menu by a highlighted tab.

    Thanks.
    Shaun.

  2. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    If you are using the latest version 1.5.3 which is available here: http://wordpress.org/themes/download/virtue.1.5.3.zip

    The css for active menu item is

    .current-menu-item

    Kadence Themes

  3. shaunvine
    Member
    Posted 2 years ago #

    Thanks for the help. I still can't get it to work.

    This is the css code I am using.

    #nav-main ul.sf-menu a:current-menu-item {
    background: #e5e2e2;
    }

    Thanks,
    Shaun.

  4. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    close you just need to change a.current-menu-item

    not :

    Kadence Themes

  5. halleran
    Member
    Posted 2 years ago #

    Will this work in the top bar too?

  6. shaunvine
    Member
    Posted 2 years ago #

    I love this Theme, and would like to figure this menu out. I made the change from : to . however it still did not work. Is there some setting that is over riding the custom css?

    Thanks for your help.
    Shaun.

  7. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    Are you using 1.5.3 from the link above. It won't work if you aren't.

    Yes this works on the topbar if using 1.5.3

    Kadence Themes

  8. shaunvine
    Member
    Posted 2 years ago #

    Yes I had updated and still no change. I am not sure what I have wrong?

    #nav-main ul.sf-menu a.current-menu-item {
    background: #e5e2e2;
    }

    Thanks.

  9. shaunvine
    Member
    Posted 2 years ago #

    Here is the link to the website.

    http://www.updatemyresite.com/

  10. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    Ok I understand. I should have looked at your link earlier and I would have put it all together in my head. So the correct call is:

    #nav-main ul.sf-menu li.current-menu-item a {background: #e5e2e2;}

    I saw you code and wasn't thinking about how it worked just that you were using wrong punctuation. My apologies.

    Kadence Themes

  11. shaunvine
    Member
    Posted 2 years ago #

    Oh! Thank you! It works perfectly.
    Thank you so much for your help.

    Regards,
    Shaun.

  12. mugeturner
    Member
    Posted 2 years ago #

    Hello,
    I also need my tabs to be highlighted (or the link put into bold would be better). I have tried the same as Shaun has done, but didn't do anything. My version is 1.5.0. (free version) I updated to the latest version on 2 days ago.
    Advice please

  13. shaunvine
    Member
    Posted 2 years ago #

    I had to download the new version of the Theme to my computer and then upload to WP as a zip file. Once I did that the custom css code worked. Maybe check your code again? Sorry I can't be of more help.

  14. mugeturner
    Member
    Posted 2 years ago #

    Cheers for the message Shaun,
    Ive clicked the link and downloaded, but how do I now update my theme?

  15. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    The next version 1.5.4 is live now so you can just update the theme

    Kadence Themes

  16. mugeturner
    Member
    Posted 2 years ago #

    Hello again,
    Ive updated now to 1.5.4 and the menu tabs are working great ow thanks. But another menu has now appeared too. i think its from some css code that i put in a while ago, but i dont know which but as i only copied and pasted from someone else. Can someone look and tell me what I need to do please?

  17. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    Can you post a link?
    I'm going to take a guess and say it's your mobile menu. Just need to be sure and set that.

    Kadence Themes

  18. mugeturner
    Member
    Posted 2 years ago #

  19. mugeturner
    Member
    Posted 2 years ago #

    its gone!!! Not sure what happened, but when i just checked that the link worked, the weird menu system has gone, so no problems!
    cheers anyway

  20. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    Try adding this to your css

    @media (max-width: 979px) {#mobile-nav-trigger {display:none;}}
    @media (max-width: 767px) {#mobile-nav-trigger {display:block;}}

    Kadence Themes

  21. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    It was there on the first load because you css hadn't fully refreshed.

    The code I just sent will make it switch to mobile cleaner

    Kadence Themes

  22. mugeturner
    Member
    Posted 2 years ago #

    Ive inserted that to and looks great. Thankyou very much for your help. I am thinking of upgrading to the premium version of Virtue. whats the easiest way to do this to minimise disruption to the site.

  23. Kadence Themes
    Member
    Theme Author

    Posted 2 years ago #

    The easiest is well... Once you purchase email me an admin login and I'll install it for you. :)

    ben@kadencethemes.com

  24. mugeturner
    Member
    Posted 2 years ago #

    OK. Will do

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags