Support » Plugin: Simple Social Icons » How to set up email uir

  • What exactly do I key in the email field as I’ve tried all permutations including the ahref and mailto: as per html. and also just my info@mail.com and nothing works. No link.
    Can you clarify please? Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Nick Cernis

    (@modernnerd)

    Hi, @wizlet130!

    You can use mailto:info@example.com.

    It’s important not to prefix that with http:// – it needs to start mailto:.

    If that still isn’t working for you, you’re welcome to share a screenshot of your settings and a link to the page where your icons appear.

    Hi Nick, thanks.
    I am putting this – no ” around anything:

    mailto:connyracher@aon.at

    And I can’t get it to open email on click.
    Any ideas?
    I am using: latest WP, Genesis Framework, Hello Pro theme.

    Plugin Contributor Nick Cernis

    (@modernnerd)

    What you have looks right to me. Have you cleared caching plugins after making this change? Could you share a link to where your icons appear?

    Hi Nick, I haven’t changed this for ages and it hasn’t worked for several weeks. I don’t have a caching plugin on the site but have disabled the hosting super cache and flushed cache. Still no go.

    Here’s the link to one site I have issues with the email uri. Another is hidden behind a coming soon plugin for now. But both have same mailto:

    http://alchemyducorps.com
    the icons are in the bottom left footer.

    Thanks!

    Plugin Contributor Nick Cernis

    (@modernnerd)

    Thanks for the link, @wizlet130.

    The mailto link on that page works well for me – it opens a new message in my email client immediately:

    new message

    So this could be specific to your machine, rather than to the two sites you mention. If mailto links fail on other sites, it would be worth checking that your computer and browser are configured with a default email client.

    (There’s a mailto link on this page if you’d like to test it on another site: https://developer.mozilla.org/en-US/docs/Learn/HTML/Introduction_to_HTML/Creating_hyperlinks#E-mail_links. The “Send email to nowhere” text works for me.)

    Hi Nick,
    Really appreciate your time on this. So it seems that the email links are working but I can’t see them on my version of Chrome. Weird! I did find them working OK viewed in mobile. At least they are working. I’ll see what I can do re my local computer then.

    Thanks so much!

    Plugin Contributor Nick Cernis

    (@modernnerd)

    Happy to help!

    Some site owners link their email button to their contact page for exactly the reason you encountered — not everyone has an email client configured, and you can always list your email address on the contact page alongside a contact form.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘How to set up email uir’ is closed to new replies.