WordPress.org

Forums

Customizr
How to set up Customizr on Google App Engine? (4 posts)

  1. perqa
    Member
    Posted 1 year ago #

    I have set up a web site using the Customizr theme, including a slider, using the plugin "Regenerate thumbnails", to produce all the image sizes I need. Everything works perfectly on my local computer, but when I deploy to Google App Engine (GAE), the images aren't displayed. I have uploaded them, and I can see them in the wp-admin Media section. They are stored on Google Cloud Storage with URLs like https://storage.googleapis.com/<bucket-name>/<image-name>.jpg, and I can access them over http on those URLs. However, on my deployed WP site, no images show up at all. Also, running the "Regenerate thumbnails" plugin does not produce any new image sizes in the storage "bucket"... I guess the plugin is not compatible with GAE at all, but how should one go about to solve this problem?

    In the developer console of my browser, I get a load of error messages like these:

    Type 1:
    The page at 'https://wp-dot-xxx-yyy-123.appspot.com/' was loaded over HTTPS, but displayed insecure content from 'http://lh4.ggpht.com/7SVmfoMBnl1kQ1su2cWZZTYQbO9KDzeuWql2TPvbnEdAS8T3N9OmUz1fv86Fws9OhoTc_7MEWjpa8MNubBHOxIJrWk4m4_NH=s99999-c': this content should also be loaded over HTTPS.

    Type 2:
    Failed to load resource: the server responded with a status of 404 (Not Found) http://lh3.ggpht.com/dQWB2UTfQKJMkQIqFBG1TL3PbgYq4GKvf88HjZdbrQQXObIGtz4rTmVkD_vfEk6EXXIm0yOGmzy2UtQv5kw3YCU4f0g-98WUrQ=s99999-c

  2. perqa
    Member
    Posted 1 year ago #

    Update:
    There are two problems here: 1) Invalid URLs and 2) http instead of https.

    #2 has nothing to do with Customizr, it's a GAE issue
    #1 can be partly fixed in Customizr by a) either disabling "full-width slider" in the admin section OR by b) modifying the file wp-content/themes/customizr/inc/class-fire-init.php

    Option b) will give you a full-width slider, but the images will cropped and scaled incorrectly. Anyway, here is the modification:

    Row 70: $this -> slider_full_size = array('width' => 99999 , 'height' => 500, 'crop' => true );

    Replace the 'width' value by a smaller number, like 9990 (note: four digits instead of five, and less than 9999).

    It would be great with a proper fix for this problem.

  3. nikeo
    Member
    Theme Author

    Posted 1 year ago #

    Hi Thanks for this feedback @perqa,

    You are right, the Google App does not seem to handle the width with more than 4 digits and works with 4 digits as shown here : http://lh3.ggpht.com/dQWB2UTfQKJMkQIqFBG1TL3PbgYq4GKvf88HjZdbrQQXObIGtz4rTmVkD_vfEk6EXXIm0yOGmzy2UtQv5kw3YCU4f0g-98WUrQ=s9999-c

    I will definitely fix this in the next release.

    You help is really appreciated!

  4. perqa
    Member
    Posted 1 year ago #

    Please check out this issue as well: https://github.com/GoogleCloudPlatform/appengine-wordpress-plugin/issues/13.

    I ended up setting both width and height to zero instead, in class-fire-init.php. That way no scaling at all occurs.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic