Support » Fixing WordPress » How to set home page only show 1 post

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hm, it’s not browser or WP (plugin) cache, since I get to posts too (next to eachtother too btw.). It DOES work on archive pages (but there you don’t show the photos). Perhaps there’s something hardcoded in the index.php of your theme?

    you are using some variant of the Hamingway theme…
    In that theme, the query is defined WITHIN the index file..
    find this line :

    $wp_query->query('showposts=2'.'&paged='.$paged);

    and try to change it to :

    $wp_query->query('showposts=1'.'&paged='.$paged);

    You can see on here : http://www.krembo99.com

    This is the same method – only for unlimited posts, using

    $wp_query->query('showposts=9999'.'&paged='.$paged);

    Great thanks to krembo99! I solve the problem now! BTW, your site is amazing, especially those pictures and the top right corner, what’s that plug?

    I’ve been trying to use a query like this to display 5 posts on front page and then my paged posts to display 10 (as set in the settings panel) .. is there any way to modify the query above to accomplish this?

    Ta,
    CK

    Use the following code instead of get header:

    <?php get_header(); query_posts(‘posts_per_page=5’); ?>

    and leave your blog settings at “display 10 posts”…that only affects your archives and categories.

    Aki, you solved my Archives problem, thank you so much!

    @zimmer -I am glad it helped and that you liked my site, but what images are you talking about ? and what plug ?

    actually I mean CyberSpy me, tks, Kern!

    changez

    (@changez)

    where i post it?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to set home page only show 1 post’ is closed to new replies.