Support » Plugin: MainWP Dashboard - The WordPress Manager for Professional Website Maintenance » How to set default index.php instead of redirection to admin.php?

  • Resolved shone83

    (@shone83)


    My admin account can login because is administrator, but if someone is editor he can’t. It sais:

    “Sorry, You Are Not Allowed to Access This Page”

    because it redirecting to admin.php instead of index.php and editor obviously don’t have permission. I don’t want for editor to see dashboard of mainwp plugin so how to fix this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi @shone83,

    By default, MainWP Dashboard is available only for Administrator users. In order to set custom redirect rule after login, please see here:
    https://codex.wordpress.org/Plugin_API/Filter_Reference/login_redirect.

    Thread Starter shone83

    (@shone83)

    I know that, but other users that are not administrator are made before I installed MainWP plugin. And now, when they login it says “Sorry, You Are Not Allowed to Access This Page”.

    I need to, just for non admin users, to go to WordPress default Dashboard, not to MainWP Dashboard. Is that possible?

    Thread Starter shone83

    (@shone83)

    I think that would solve the problem if is set that all users, along with administrator, after login redirect to default worpdress dashboard instead of mainwp, and if I as administrator want to go to mainwp dashboard just go manually. How can I do that?

    Hi @shone83,

    In the upcoming MainWP 4 version, the redirection after login has been removed. After login, all users will be redirected to the WordPress Dashboard page.

    Thread Starter shone83

    (@shone83)

    So, I have to wait for 4 version? It’s strange that now you don’t have a option for that, because I guess that many other people have more than one users on their sites and not all is administrators…

    When a new vesion would be released?

    Pozdrav Sanja.

    • This reply was modified 2 years, 5 months ago by shone83.

    Hi @shone83,

    If you want you can grab the MainWP 4.0-RC2 from here so you don’t have to wait for the official update.
    Since we recommend running the MainWP Dashboard on a dedicated clean WP installation and most people do that we haven’t had requests about removing the redirection rule so far.

    Pozdrav

    Thread Starter shone83

    (@shone83)

    I did all that but redirection after login is not removed. Still can’t login with editor user without error.

    Hi @shone83,

    Please open a support ticket in our helpdesk so we can check this for you.

    Plugin Author mainwp

    (@mainwp)

    Issue resolved in the helpdesk ticket #34064.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘How to set default index.php instead of redirection to admin.php?’ is closed to new replies.