WordPress.org

Forums

Contact Form 7 Modules
[resolved] How to send only fields which contain content? (3 posts)

  1. MediaCoCo
    Member
    Posted 1 year ago #

    Hi there,
    Im using the [all-fields] shortcode.
    It includes all fields, even those which are empty.
    For every empty field it shows an empty row in my email.

    Example:
    My form has 200 fields, even though the customer fills in only 15, the e-mail im receiving contains 185 empty rows + the 15 filled in fields..

    Is there anything I can do to avoid that?
    I want only the fields which are NOT EMPTY.

    I'd appreciate any help on this.

    Thanks

    https://wordpress.org/plugins/contact-form-7-modules/

  2. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    This is enabled by default now in version 1.4.2, just released.

    If you want to turn back on sending empty fields, see the FAQ item "How do I send empty values with the [all-fields] shortcode?"

    If you want to donate, that'd be great!

  3. MediaCoCo
    Member
    Posted 1 year ago #

    Thank you so much! Update works like charm! (:

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7 Modules
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic