WordPress.org

Ready to get started?Download WordPress

Forums

How to send email when there is a new Comment? (20 posts)

  1. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    I don't seem to see where there is a setting to configure sending an email whenever there is a new Comment made to a post. I'm guessing this should be possible?

  2. myinstinctwaswrong
    Member
    Posted 6 years ago #

    this works on our blog - we require registration and also moderate the first post of anyone.

    Once a user gets an "approved" comment - any further comments are posting automatically.

    in every case - comments that need moderation first come to me - once I approve them - the post author also gets an email.

  3. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Cool! That's my question. Where do I configure an email notification to me when someone has entered a comment. Instead of having to continually review the blog to see if there are any comments I would like to be notified so that I can review and approve.

  4. Saurus
    Member
    Posted 6 years ago #

    It's in your Dashboard.

  5. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Appreciate the short but sweet answer Saurus. I already looked in the Dashboard as I figured that is where I should find it. However, I didn't which is why I posted the question. Sure would appreciate a little more meat to your answer.

  6. adams2008
    Member
    Posted 6 years ago #

    in the settings / discussion tab you can change your comment options to "e-mail you whenever ..." and other comment moderation fields.

    To get everyone to register on your blog before they leave a comment, go to the settings / general tab and click "Membership - anyone can register"

  7. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Thanks adams2008.

    I checked their originally prior to posting my question. It is already checked and I am not receiving any emails when comments are left so I was wondering if there is some other setting that needs to happen.

    I don't have the blog setup for people to register and for now have elected not to. I just want to receive email notification when someone has left a comment so I don't have to check the blog daily.

  8. chanel
    Member
    Posted 6 years ago #

    Which wordpress version are you running? In version 2.7:

    1)Settings
    2)Discussion
    3)E-mail me whenever

    And then you can check off "Anyone posts a comment"

    You don't need users to register for your blog in order to be notified by email. To verify you have the right email go to the top right hand corner and click on "Howdy, your name". That should take you to your admin profile.

  9. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Thanks Chanel

    Version 2.7. That is exactly how I have it configured already. There must some setting somewhere to tell it how it should send, like what email server etc.

  10. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    anyone?

  11. xrun
    Member
    Posted 6 years ago #

    I second this, need help with the same. I've also checked the settings, they are as described above.

  12. fee27
    Member
    Posted 6 years ago #

    I am having the same problem - all the settings as above are correct and this is now begining to bug me that I cant find an answer here =) Seems a lot of people are having the same problem but no one seems to know the answers. I'm not sure if it has something to do with the fact that I want email notifications to get sent to my gmail address or something else.
    Also new users aren't getting their password notification emails either.....

  13. imadam
    Member
    Posted 6 years ago #

    could this be due to php mail() being disabled? i am trying to get the blog i am currently running here http://sallyandrew.findhornpress.com to email me when a comment is posted however i get nothing, the same for when i reset my password i never get an email which i assume is because php mail is disabled. is there any work around to this?

    perhaps this is why other users have this problem?

  14. mednovus
    Member
    Posted 6 years ago #

    Also, are you sure you're getting valid comments? I got notified of comments ALL THE TIME, but 99% of them were spam (the advantage of WordPress is that everyone can find your blog easily... the disadvantage of WordPress is that every spammer on the globe can also find your blog easily...).

    I installed Akismet spam filter and now I only get notifications of _real_ comments. It has dramatically slashed the wasted time deleting ads for pharma or porn...

  15. xrun
    Member
    Posted 6 years ago #

    I'm looking av 6 comments from real people, but even with the settings in wp I did not get notifications about them on email.

  16. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Yes, all the comments I am getting are indeed "valid". It seems really odd here that so many of us are experiencing the same thing and no one seems to have an answer.

  17. monk@loosemonkey.net
    Member
    Posted 6 years ago #

    Hello all... not much activity on this topice in a while however, the issue still exists.

    I am guessing there is something else going on here with regards to no emails being sent from the blog when someone ads a comment.

    1. Is there some setting within WordPress I need to make in order to tell it what mail server to send from?
    2. Is there some setting in PHP I need to make to setup a mail server?
    3. Is there some setting in MySQL I need to make to setup a mail server?

  18. janvandam
    Member
    Posted 5 years ago #

    I'm using the latest wp version. When someone comments on my blog he's receiving automaticaly an email for conformation.
    When approving there's another option: reply. What I would like is that this reply of mine wil be sent to the commentor by mail so he knows that I commented on mis comment.

    Can anybody help??

  19. swyuda
    Member
    Posted 5 years ago #

    I found this article maybe this could help

    http://www.networknet.nl/apps/wp/archives/714

  20. Carl Harris
    Member
    Posted 5 years ago #

    This works perfectly.
    I host with FASTHOSTS and changed the setting as above.
    Job Done!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.