Support » Theme: Allegiant » How to select Blog page

  • I’m selecting the Only Blog page to A static page. but home page auto change to the blog page. how I select the only blog page.

    Settings -> Reading Settings -> A static page (select below)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello @atiq29,

    To solve this I recommend to create an empty page and then choose that as your homepage.
    This will solve it.

    Warmly,
    Mihaela

    Thanks for reply @mplusb,
    I create an empty page but after created in home page blog section is showing I disable from Customizing but it’s not hidden. I remove blog code from index.php but it is still showing.
    this is code I remove:-

    <?php if ( cpotheme_show_posts() ) : ?>
    <div id="main" class="main">
    	<div class="container">		
    		<section id="content" class="content">
    			<?php do_action( 'cpotheme_before_content' ); ?>
    			<?php
    			if ( have_posts() ) {
    				while ( have_posts() ) :
    					the_post();
    				?>
    							<?php get_template_part( 'template-parts/element', 'blog' ); ?>
    			<?php
    			endwhile;
    			};
    ?>
    			<?php cpotheme_numbered_pagination(); ?>
    			<?php do_action( 'cpotheme_after_content' ); ?>
    		</section>
    		<?php get_sidebar(); ?>
    		<div class="clear"></div>
    	</div>
    </div>
    <?php endif; ?>

    Hello @atiq29,

    Please go to Appearance > Customize > Layout > Blog Posts > and turn off Enable Posts On Homepage > save and this should remove posts from your homepage.

    Warmly,
    Mihaela

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.