Support » Plugins and Hacks » How To: Revert to the last version of W3TC

How To: Revert to the last version of W3TC

  • I have been following the technical issues with the W3TC plugin and I love the thing but can’t use it now because it is making the site break. Is there a step-by-step on how to revert to the older version of the plugin? Also, if I do this, will I lose all of my settings?

    Thanks in advance

Viewing 15 replies - 1 through 15 (of 33 total)
  • Go to http://wordpress.org/extend/plugins/w3-total-cache/download/

    Download the version and manually upload the files.

    thanks for the reply ipstenu… I did this already and i tried uploading the zipped plugin via the wp admin. unfortunately, the newer version of the plugin is still installed. so, do I delete the newer version first, then upload the older version?

    Also, am I going to lose my settings?

    Try a REAL manual upload ­čÖé Open up FTP and copy the files up.

    If that fails, delete. You SHOULD NOT lose your settings, but you can export them (bottom of the general page) first if you’re worried.

    You don’t need to revert to the prior version. Apply the fix below. Press the buttons to reload the CDN and clear the browser cache after the fix. Try from a browser with and without you logged into the wordpress site.

    From @w3edge on twitter “users need to switch minify to manual minify mode”.
    The fix seemed to work for me.

    thanks again ipstenu. performing the upload now.

    Obrun, I actually tried that too, but it still seemed to be making things a bit funky. I still a newbie with this plugin, so I wanted to keep the guess work to a minimum.


    Toggling Minify from Auto to Manual seems to of fixed things for me… haven’t throughly tested the site out but so far so good.

    THANKS @obrun

    Reverted back to Now I get asked if I am sure that I want to leave the page every time I try to save changes. Is this something to worry about?


    Are you on Chrome?

    wow, that was a very long work around. I went to the server, took down the new W3TC release and reinstalled the last version. That served a 500 Internal Server Error. I had to reboot the server, delete the .htaccess files and do a trial and error of install and delete with my plugins.

    Ultimately, the site/server are back up, the google page speed is back at 97/100 and the site is restored.

    I think I will hold off on the upgrade ;-)!

    Thank @obrun and @jb510 for checking it out as well. That did it for me. I found that the “compatibility check” acted a bit funky though…maybe a lightbox issue. Time to update the update I think.

    Yeah, the compat check and other help bits like that are acting up for everyone. Frederick said he’s working on that.

    @ipstenu, that’s interesting. I am not using Chrome. But I just tried using Firefox and Safari. It only happens with Firefox.

    And the bug in servers running Nginx?

    In my case i see many Error 500 menssages after update.

    @jason – I see it on Chrome, but only sometimes, and I think it’s not W3TC, but Chrome being weird.

    There’s another update,

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘How To: Revert to the last version of W3TC’ is closed to new replies.