Support » Plugin: Wordfence Security - Firewall & Malware Scan » How to resolve PHP environment errors?

  • Resolved Techeshta

    (@techeshta)


    Hello plugin support team,

    Recently I transferred my website to new hosting details and I am newbie with this kind of hosting.

    When I was checking all Wordfence option and that time I noticed that I have not good PHP environment settings to run Wordfence plugin.

    Screenshot – https://prnt.sc/m4fmf3

    Let me know if you have clue to resolve it and get benefits of this security plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @techeshta,

    Can you ask your host for assistance in enabling or installing the cURL extension for PHP?

    If you have access to root access on your host, you can run these commands:

    1. sudo apt-get install curl
    2. sudo apt-get install php5-curl
    3. sudo service apache2 restart

    Dave

    Thread Starter Techeshta

    (@techeshta)

    While trying your step 2,

    It throwing this –

    Package php5-curl is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘php5-curl’ has no installation candidate

    Hi again!

    If you could provide me with your system details (Linux distro and version, for example Ubuntu 16.04), that would help a lot!

    I do have another command you can try however:

    sudo apt-get install php-curl

    I just noticed I shouldn’t have included the version number, because you may be on php7.0.

    Dave

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘How to resolve PHP environment errors?’ is closed to new replies.