Support » Plugin: Subscribe2 - Form, Email Subscribers & Newsletters » How to resolve GDPR message?

  • Resolved mandy@nepeta

    (@mandynepeta)


    Good morning
    I have just updated to version 10.26.1 and am now getting the message “Your Settings may breach GDPR”. I have checked all my settings and cannot see any indication of where the problem may lie, or anything wrong. this means that I cannot see or solve the problem.

    Could you please either provide warnings on the relevant setting or some guidance on why you are issuing the message?

    Thank you

    Mandy

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mattyrob

    (@mattyrob)

    @mandynepeta

    This warning will show if you have certain auto-subscribe settings turned to Yes in Subscribe2 -> Settings under the Registered User Tab.

    The settings specifically are:
    ‘Registration Form option is checked by default’
    ‘Option for Registered Users to auto-subscribe to new categories is checked by default’
    ‘Comment form checkbox is checked by default’

    GDPR requires affirmative action from end users and checking boxes by default is highly discouraged. You can disable this warning if you wish by adding the following line to a plugin or your themes functions.php file:
    define( 'S2GDPR', false )

    Thank you for the clarification. We are only using the plugin for guest subscriptions, so are OK but I will switch the settings to get rid of the message.

    May I suggest you add this info or a link to it to the message? It might make it a bit longer but it would save a lot of head scratching.

    Thanks for the prompt response.

    Mandy

    @mattyrob per your instructions I added the following line to a site’s child theme functions.php file:

    define( ‘S2GDPR’, false );

    (Adding it without the semi-colon at the end broke the site)

    The error continues to appear. Can you clarify further?

    TIA!

    Plugin Support mattyrob

    (@mattyrob)

    @richsadams

    S@GDPRis actually defined as true in the core plugin file – subscribe2.php. I suspect your definition of that constant is being over-ridden.

    Instead of my instruction above, change that in the subscribe2.php file at wp-content/plugins/subscribe2/subscribe2.php.

    @mattyrob

    Success!

    I changed line #61 in subscribe2.php:

    From: define( ‘S2GDPR’, true );

    To: define( ‘S2GDPR’, false );

    That did the trick.

    Thanks very much for the ├╝ber fast reply and keep up the great work!

    Best wishes,

    Rich

    • This reply was modified 4 months, 2 weeks ago by  richsadams.
    • This reply was modified 4 months, 2 weeks ago by  richsadams.
    • This reply was modified 4 months, 2 weeks ago by  richsadams.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.